How to get Mouse Down to activate button? Missing Touch down event in app code.

Asked by Peter Benjamin

Could the NextWindow driver be dropping a touch (mouse left_btn) down event? The RealBasic app is never seeing the first touch down event. The touch when lifted does generate a Mouse Up, 273 code, and buttons are activated in the RealBasic app. The idea is to get the initial touch to activate the button.

Everything works fine on the old HP 310 with the Quanta touchscreen with a mod to evdev.c to map code 330 to code 272. We know HP hardware changes have Ubuntu installing slightly differently, and we'd like to eliminate the possibility of it being an issue inside NextWindow driver, thus the question here.

I'm on the new HP 320 1020 series computer, and got the NextWindow touchscreen working (though not working on the HP 320 1050, but that's later). Now, I want the results of a Touch Down (mouse left button down) to be the same action as a Touch Up (mouse left button up), where X11, Gnome 3, and RealBasic have an application running that shows the users buttons. Just pressing on the button should activate it.

It appears that evtest, evbug (code=272, value=1), and xinput (button 1 press) are all showing the Touch Down event (as a 272 emulating a mouse), but the RealBasic app is not getting the event. All the right log messsages are in kern.log, syslog, and Xorg.0.log.

I have been adding debug printk statements to nwfermi.c They show what I would expect, and evbug matches the nwfermi.c. appears to have the calls to xf86PostButtonEvent, and seems to be working fine, as evbug is showing output. It's not clear to me that any NextWindow drivers are at fault, and yet the GTK/RealBasic application is not passed any mouse left button down events. The wireless mouse does work, and shows the same 272 via evbug.

The one difference I do see, is evbug for mouse shows no XY entries, while for NextWindows there are XY entries. I'm thinking those XY entries may not be passed correctly to GTK, or GTK is not passing them to RealBasic.

Software: Ubuntu 11.04, with fglrx and xf86-input-nextwindow installed.

lsusb stdout snippet:
Bus 006 Device 002: ID 1926:0dbc NextWindow

Any other information is needed? I've done quite a lot of steps, so, so many, too many to list here.

Question information

English Edit question
nwfermi Edit question
No assignee Edit question
Solved by:
Peter Benjamin
Last query:
Last reply:
Revision history for this message
Peter Benjamin (pete-launchpad-u) said :

The problem was solved with UseTouchHelp "0" in the /usr/share/X11/xorg.conf.d/70_nwfermi.conf file.