no sound on xubuntu

Asked by dagion on 2010-01-11

I have a onboard and pci sound card they both show up but don't seem to work.

**** List of PLAYBACK Hardware Devices ****
card 0: Live [SB Live! Value [CT4780]], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
  Subdevices: 31/32
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
  Subdevice #8: subdevice #8
  Subdevice #9: subdevice #9
  Subdevice #10: subdevice #10
  Subdevice #11: subdevice #11
  Subdevice #12: subdevice #12
  Subdevice #13: subdevice #13
  Subdevice #14: subdevice #14
  Subdevice #15: subdevice #15
  Subdevice #16: subdevice #16
  Subdevice #17: subdevice #17
  Subdevice #18: subdevice #18
  Subdevice #19: subdevice #19
  Subdevice #20: subdevice #20
  Subdevice #21: subdevice #21
  Subdevice #22: subdevice #22
  Subdevice #23: subdevice #23
  Subdevice #24: subdevice #24
  Subdevice #25: subdevice #25
  Subdevice #26: subdevice #26
  Subdevice #27: subdevice #27
  Subdevice #28: subdevice #28
  Subdevice #29: subdevice #29
  Subdevice #30: subdevice #30
  Subdevice #31: subdevice #31
card 0: Live [SB Live! Value [CT4780]], device 2: emu10k1 efx [Multichannel Capture/PT Playback]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 0: Live [SB Live! Value [CT4780]], device 3: emu10k1 [Multichannel Playback]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: I82801DBICH4 [Intel 82801DB-ICH4], device 0: Intel ICH [Intel 82801DB-ICH4]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: I82801DBICH4 [Intel 82801DB-ICH4], device 4: Intel ICH - IEC958 [Intel 82801DB-ICH4 - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
  *-multimedia
       description: Multimedia audio controller
       product: SB Live! EMU10k1
       vendor: Creative Labs
       physical id: 1
       bus info: pci@0000:02:01.0
       version: 0a
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: driver=EMU10K1_Audigy latency=32 maxlatency=20 mingnt=2
       resources: irq:22 ioport:d880(size=32)
  *-multimedia
       description: Multimedia audio controller
       product: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
       vendor: Intel Corporation
       physical id: 1f.5
       bus info: pci@0000:00:1f.5
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: driver=Intel ICH latency=0
       resources: irq:17 ioport:e400(size=256) ioport:e080(size=64) memory:febff800-febff9ff memory:febff400-febff4ff
H/W path Device Class Description
====================================================
                             system E-4000
/0 bus D845GRG
/0/0 memory 64KiB BIOS
/0/4 processor Intel(R) Pentium(R) 4 CPU 2.00GHz
/0/4/5 memory 8KiB L1 cache
/0/4/6 memory 512KiB L2 cache
/0/2f memory 1GiB System Memory
/0/2f/0 memory 512MiB DIMM DDR Synchronous 266 MHz (3.
/0/2f/1 memory 512MiB DIMM DDR Synchronous 266 MHz (3.
/0/100 bridge 82845G/GL[Brookdale-G]/GE/PE DRAM Contr
/0/100/1 bridge 82845G/GL[Brookdale-G]/GE/PE Host-to-AG
/0/100/1/0 display NV34 [GeForce FX 5200]
/0/100/1d bus 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) US
/0/100/1d.1 bus 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) US
/0/100/1d.2 bus 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) US
/0/100/1d.7 bus 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Con
/0/100/1e bridge 82801 PCI Bridge
/0/100/1e/0 wlan0 network 88w8335 [Libertas] 802.11b/g Wireless
/0/100/1e/1 multimedia SB Live! EMU10k1
/0/100/1e/1.1 input SB Live! Game Port
/0/100/1e/8 eth0 network 82801DB PRO/100 VE (LOM) Ethernet Contr
/0/100/1f bridge 82801DB/DBL (ICH4/ICH4-L) LPC Interface
/0/100/1f.1 scsi0 storage 82801DB (ICH4) IDE Controller
/0/100/1f.1/0 /dev/dvd disk DVD SHD-16P1S
/0/100/1f.1/1 /dev/cdrom disk CD-R/CD-RW writer
/0/100/1f.1/2 /dev/sda disk 80GB WDC WD800JB-00JJ
/0/100/1f.1/2/1 /dev/sda1 volume 956MiB EXT4 volume
/0/100/1f.1/2/2 /dev/sda2 volume 73GiB EXT4 volume
/0/100/1f.1/3 /dev/sdb disk 81GB Maxtor 6L080L0
/0/100/1f.1/3/1 /dev/sdb1 volume 9538MiB Linux swap volume
/0/100/1f.1/3/2 /dev/sdb2 volume 67GiB EXT4 volume
/0/100/1f.3 bus 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SM
/0/100/1f.5 multimedia 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC
/0/1 scsi2 storage
/0/1/0.0.0 /dev/sdc disk 2038MB SCSI Disk
/0/1/0.0.0/1 /dev/sdc1 volume 1943MiB Windows FAT volume
total 0
crw-rw----+ 1 root audio 116, 2 2010-01-11 09:37 timer
crw-rw----+ 1 root audio 116, 3 2010-01-11 09:37 seq
crw-rw----+ 1 root audio 116, 6 2010-01-11 09:37 pcmC0D3p
crw-rw----+ 1 root audio 116, 15 2010-01-11 09:37 midiC0D2
crw-rw----+ 1 root audio 116, 5 2010-01-11 09:37 midiC0D0
crw-rw----+ 1 root audio 116, 4 2010-01-11 09:37 hwC0D0
crw-rw----+ 1 root audio 116, 8 2010-01-11 09:37 pcmC0D2c
crw-rw----+ 1 root audio 116, 9 2010-01-11 09:37 pcmC0D1c
crw-rw----+ 1 root audio 116, 13 2010-01-11 09:37 hwC0D2
crw-rw----+ 1 root audio 116, 12 2010-01-11 09:37 controlC0
crw-rw----+ 1 root audio 116, 14 2010-01-11 09:37 midiC0D1
crw-rw----+ 1 root audio 116, 18 2010-01-11 09:37 pcmC1D2c
crw-rw----+ 1 root audio 116, 19 2010-01-11 09:37 pcmC1D1c
crw-rw----+ 1 root audio 116, 16 2010-01-11 09:37 pcmC1D4p
crw-rw----+ 1 root audio 116, 17 2010-01-11 09:37 pcmC1D3c
crw-rw----+ 1 root audio 116, 22 2010-01-11 09:37 controlC1
drwxr-xr-x 2 root root 80 2010-01-11 09:37 by-path
drwxr-xr-x 3 root root 480 2010-01-11 09:37 .
crw-rw----+ 1 root audio 116, 7 2010-01-11 10:05 pcmC0D2p
crw-rw----+ 1 root audio 116, 10 2010-01-11 10:05 pcmC0D0p
crw-rw----+ 1 root audio 116, 11 2010-01-11 10:05 pcmC0D0c
crw-rw----+ 1 root audio 116, 20 2010-01-11 10:05 pcmC1D0p
crw-rw----+ 1 root audio 116, 21 2010-01-11 10:05 pcmC1D0c
drwxr-xr-x 16 root root 4160 2010-01-11 10:05 ..
Sound Driver:3.8.1a-980706 (ALSA v1.0.20 emulation code)
Kernel: Linux zero 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
SB Live! Value [CT4780] (rev.10, serial:0x80221102) at 0xd880, irq 22
Intel 82801DB-ICH4 with AD1981A at irq 17

Audio devices:
0: ADC Capture/Standard PCM Playback (DUPLEX)
1: Intel 82801DB-ICH4 (DUPLEX)

Synth devices:
0: Emu10k1

Midi devices:
0: EMU10K1 MPU-401 (UART)

Timers:
31: system timer

Mixers:
0: Cirrus Logic CS4297A rev 4
1: Analog Devices AD1981A
00:00.0 Host bridge [0600]: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface [8086:2560] (rev 01)
00:01.0 PCI bridge [0604]: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE Host-to-AGP Bridge [8086:2561] (rev 01)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 [8086:24c2] (rev 01)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 [8086:24c4] (rev 01)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 [8086:24c7] (rev 01)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller [8086:24cd] (rev 01)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev 81)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge [8086:24c0] (rev 01)
00:1f.1 IDE interface [0101]: Intel Corporation 82801DB (ICH4) IDE Controller [8086:24cb] (rev 01)
00:1f.3 SMBus [0c05]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller [8086:24c3] (rev 01)
00:1f.5 Multimedia audio controller [0401]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller [8086:24c5] (rev 01)
01:00.0 VGA compatible controller [0300]: nVidia Corporation NV34 [GeForce FX 5200] [10de:0322] (rev a1)
02:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless [11ab:1faa] (rev 03)
02:01.0 Multimedia audio controller [0401]: Creative Labs SB Live! EMU10k1 [1102:0002] (rev 0a)
02:01.1 Input device controller [0980]: Creative Labs SB Live! Game Port [1102:7002] (rev 0a)
02:08.0 Ethernet controller [0200]: Intel Corporation 82801DB PRO/100 VE (LOM) Ethernet Controller [8086:1039] (rev 81)
/sbin/alsactl
                     USER PID ACCESS COMMAND
/dev/snd/controlC0: one 1741 F.... xfce4-mixer-plu
                     one 1761 F.... xfce4-volumed
                     one 3381 F.... pulseaudio
/dev/snd/controlC1: one 1741 F.... xfce4-mixer-plu
                     one 1761 F.... xfce4-volumed
                     one 3381 F.... pulseaudio
dpkg: *bin/slmodemd* not found.
sudo: /etc/init.d/sl-modem-daemon: command not found
snd_emu10k1_synth 6140 0
snd_emux_synth 32860 1 snd_emu10k1_synth
snd_seq_virmidi 5628 1 snd_emux_synth
snd_seq_midi_emul 6332 1 snd_emux_synth
snd_intel8x0 30168 4
snd_emu10k1 135136 7 snd_emu10k1_synth
snd_seq_dummy 2656 0
snd_ac97_codec 101216 2 snd_intel8x0,snd_emu10k1
ac97_bus 1532 1 snd_ac97_codec
snd_pcm_oss 37920 0
snd_mixer_oss 16028 3 snd_pcm_oss
snd_seq_oss 28576 0
snd_seq_midi 6432 0
snd_pcm 75296 4 snd_intel8x0,snd_emu10k1,snd_ac97_codec,snd_pcm_oss
snd_rawmidi 22208 3 snd_seq_virmidi,snd_emu10k1,snd_seq_midi
snd_seq_midi_event 6940 3 snd_seq_virmidi,snd_seq_oss,snd_seq_midi
snd_util_mem 4156 2 snd_emux_synth,snd_emu10k1
snd_seq 50224 9 snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_hwdep 7200 2 snd_emux_synth,snd_emu10k1
snd_timer 22276 3 snd_emu10k1,snd_pcm,snd_seq
snd_seq_device 6920 8 snd_emu10k1_synth,snd_emux_synth,snd_emu10k1,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 59204 30 snd_emux_synth,snd_seq_virmidi,snd_intel8x0,snd_emu10k1,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_seq_oss,snd_pcm,snd_rawmidi,snd_seq,snd_hwdep,snd_timer,snd_seq_device
soundcore 7264 3 snd
snd_page_alloc 9156 3 snd_intel8x0,snd_emu10k1,snd_pcm

Question information

Language:
English Edit question
Status:
Solved
For:
NULL Project Edit question
Assignee:
No assignee Edit question
Solved by:
dagion
Solved:
Last query:
Last reply:
Revision history for this message
dagion (lunachis) said :
#1

pcm was muted

Revision history for this message
Guiseppe Maggio (guisepp) said :
#5

 Thanks for the info i will try to figure it out for more

https://www.krogerfeed.us/

Revision history for this message
Alessandro (boyerr) said :
#6

There could be various reasons why there is no sound in Ubuntu. The fix depends on the kind of problem you have. Before you take the steps to fix it, I suggest get some information about your system, specially about the audio related hardware.

https://www.firstcallonline.us/