Installation with Synaptic and PPA fails

Asked by Jonathon Hodges on 2009-02-17

Hi Jean-Peer,
I'm embarrassed to come and ask for help as soon as my first time with NSsbackup but I've followed the instructions for installing through Synaptic and it fails, due to dependency problems. NSsbackup doesn't run after installation and the terminal reports the following in Synaptic:

Selecting previously deselected package nssbackup-common.
(Reading database ... 126557 files and directories currently installed.)
Unpacking nssbackup-common (from .../nssbackup-common_0.2-0~rc3-ppa1_all.deb) ...
Selecting previously deselected package nssbackup-ftp.
Unpacking nssbackup-ftp (from .../nssbackup-ftp_0.2-0~rc3-ppa1_all.deb) ...
Selecting previously deselected package nssbackup-gtk.
Unpacking nssbackup-gtk (from .../nssbackup-gtk_0.2-0~rc3-ppa1_all.deb) ...
Selecting previously deselected package nssbackup-ssh.
Unpacking nssbackup-ssh (from .../nssbackup-ssh_0.2-0~rc3-ppa1_all.deb) ...
Selecting previously deselected package nssbackup.
Unpacking nssbackup (from .../nssbackup_0.2-0~rc3-ppa1_all.deb) ...
Processing triggers for menu ...
Setting up nssbackup-common (0.2-0~rc3-ppa1) ...
------------------------------------------------------------
NSsbackup 0.2-0 RC3 upgrade tool
------------------------------------------------------------
errors occurred:
Traceback (most recent call last):
  File "/usr/sbin/nssbackupconfig", line 331, in <module>
    RETC = _UPGRADER.main()
  File "/usr/sbin/nssbackupconfig", line 323, in main
    retcode = self.__logoption_upgrader.do_upgrade()
  File "/usr/sbin/nssbackupconfig", line 287, in do_upgrade
    self._read_logindefs()
  File "/usr/sbin/nssbackupconfig", line 173, in _read_logindefs
    self.__min_uid = int(defssplit[1])
ValueError: invalid literal for int() with base 10: ''
dpkg: error processing nssbackup-common (--configure):
 subprocess post-installation script returned error exit status 9
dpkg: dependency problems prevent configuration of nssbackup-ftp:
 nssbackup-ftp depends on nssbackup-common (= 0.2-0~rc3-ppa1); however:
  Package nssbackup-common is not configured yet.
dpkg: error processing nssbackup-ftp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nssbackup-gtk:
 nssbackup-gtk depends on nssbackup-common (= 0.2-0~rc3-ppa1); however:
  Package nssbackup-common is not configured yet.
dpkg: error processing nssbackup-gtk (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nssbackup-ssh:
 nssbackup-ssh depends on nssbackup-common (= 0.2-0~rc3-ppa1); however:
  Package nssbackup-common is not configured yet.
dpkg: error processing nssbackup-ssh (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nssbackup:
 nssbackup depends on nssbackup-ftp (= 0.2-0~rc3-ppa1); however:
  Package nssbackup-ftp is nNo apport report written because the error message indicates its a followup error from a previous failure.
                                                      No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                            ot configured yet.
 nssbackup depends on nssbackup-gtk (= 0.2-0~rc3-ppa1); however:
  Package nssbackup-gtk is not configured yet.
 nssbackup depends on nssbackup-ssh (= 0.2-0~rc3-ppa1); however:
  Package nssbackup-ssh is not configured yet.
dpkg: error processing nssbackup (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 nssbackup-common
 nssbackup-ftp
 nssbackup-gtk
 nssbackup-ssh
 nssbackup
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up nssbackup-common (0.2-0~rc3-ppa1) ...
------------------------------------------------------------
NSsbackup 0.2-0 RC3 upgrade tool
------------------------------------------------------------
errors occurred:
Traceback (most recent call last):
  File "/usr/sbin/nssbackupconfig", line 331, in <module>
    RETC = _UPGRADER.main()
  File "/usr/sbin/nssbackupconfig", line 323, in main
    retcode = self.__logoption_upgrader.do_upgrade()
  File "/usr/sbin/nssbackupconfig", line 287, in do_upgrade
    self._read_logindefs()
  File "/usr/sbin/nssbackupconfig", line 173, in _read_logindefs
    self.__min_uid = int(defssplit[1])
ValueError: invalid literal for int() with base 10: ''
dpkg: error processing nssbackup-common (--configure):
 subprocess post-installation script returned error exit status 9
dpkg: dependency problems prevent configuration of nssbackup-gtk:
 nssbackup-gtk depends on nssbackup-common (= 0.2-0~rc3-ppa1); however:
  Package nssbackup-common is not configured yet.
dpkg: error processing nssbackup-gtk (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nssbackup-ssh:
 nssbackup-ssh depends on nssbackup-common (= 0.2-0~rc3-ppa1); however:
  Package nssbackup-common is not configured yet.
dpkg: error processing nssbackup-ssh (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nssbackup-ftp:
 nssbackup-ftp depends on nssbackup-common (= 0.2-0~rc3-ppa1); however:
  Package nssbackup-common is not configured yet.
dpkg: error processing nssbackup-ftp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nssbackup:
 nssbackup depends on nssbackup-ftp (= 0.2-0~rc3-ppa1); however:
  Package nssbackup-ftp is not configured yet.
 nssbackup depends on nssbackup-gtk (= 0.2-0~rc3-ppa1); however:
  Package nssbackup-gtk is not configured yet.
 nssbackup depends on nssbackup-ssh (= 0.2-0~rc3-ppa1); however:
  Package nssbackup-ssh is not configured yet.
dpkg: error processing nssbackup (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 nssbackup-common
 nssbackup-gtk
 nssbackup-ssh
 nssbackup-ftp
 nssbackup

Kind regards,
Jonathon

Question information

Language:
English Edit question
Status:
Solved
For:
nssbackup Edit question
Assignee:
No assignee Edit question
Solved by:
Jean-Peer Lorenz
Solved:
2009-02-20
Last query:
2009-02-20
Last reply:
2009-02-18
Best Jean-Peer Lorenz (peer.loz) said : #1

Hey Jonathon,

I'm very sorry for your trouble. I discovered the reported issue just after releasing RC3. I've already fixed it and will release an update this night (hopefully).

Best regards,

Jean-Peer.

Jonathon Hodges (jonblondie) said : #2

Thanks Jean-Peer Lorenz, that solved my question.