novnc and nova-novncproxy conflict on install

Asked by Cody Sandwith on 2013-05-14

As per the guide offered at
on the bottom of page 11, the document says I should run the following command to install nova:
# apt-get install -y nova-api nova-cert nova-common nova-conductor \
 nova-scheduler python-nova python-novaclient nova-consoleauth novnc \

However, aptitude shows me the following error, and apparently, nova-novncproxy does not install successfully:
"Unpacking nova-novncproxy (from .../nova-novncproxy_1%3a2013.1-0ubuntu2~cloud1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/nova-novncproxy_1%3a2013.1-0ubuntu2~cloud1_all.deb (--unpack):
 trying to overwrite '/usr/bin/nova-novncproxy', which is also in package novnc 1:0.4+dfsg+1-6"

Now, I'm still learning about Openstack, but I'm gonna go out on a limb and assume that I need novncproxy. What should I do to install it? Should I do something like:
sudo rm -rf /usr/bin/nova-novncproxy && sudo apt-get install nova-novncproxy

Tried a couple more things. I did:
sudo apt-get remove novnc nova-novncproxy (which only removed novnc, as nova-novncproxy never installed correctly)
sudo dpkg --force-overwrite --purge novnc nova-novncproxy
And then
sudo apt-get install nova-novncproxy
Which, I was hoping, would JUST install nova-novncproxy (so that I could install it before installing novnc, to see if that would clear anything up). Instead, I got:
"The following extra packages will be installed:
The following NEW packages will be installed:
  nova-novncproxy novnc"
And, of course, the same error.

Any help is appreciated

Question information

English Edit question
OpenStack Compute (nova) Edit question
No assignee Edit question
Last query:
Last reply:
Bill Weber (bill-weber) said : #1

Can reproduce this problem with both Ubuntu 13.04 and 12.04.

Bill Weber (bill-weber) said : #2

forced package by running
dpkg -i --force-overwrite /var/cache/apt/archives/nova-novncproxy_1%3a2013.1-0ubuntu2~cloud1_all.deb

Cody Sandwith (kungfujoe1110) said : #3

I hope the status "answered" is distinct from "resolved". Telling dpkg to force overwrite files is hackish at best.
That said, using the hack, I am able to move on, but technically speaking this bug is not resolved.

Doing the --force-overwrite does install nova-novncproxy but further package installation cause errors like:

The following packages have unmet dependencies:
 nova-novncproxy : Depends: nova-common (= 2013.1-2) but 2013.1.2-2~bpo70+1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

So I uninstalled nova-nonvcproxy by dpkg --remove nova-novncproxy

and as i was setting up the controller node - I installed nova-consoleproxy which AFAIK acts as a frontend proxy for novnc, spicehtml5 and other types of console viewers. That got installed and along with it came /etc/init.d/nova-nonvcproxy

nova-consoleproxy decides which console viewer to use depending on the value set in /etc/default/nova-consoleproxy. I updated it to have novnc and then doing:

ls /etc/init.d/nova* | while read line; do $line restart; done

started nova-novncproxy along with the usual set of services.

Hope this helps.


Can you help with this problem?

Provide an answer of your own, or ask Cody Sandwith for more information if necessary.

To post a message you must log in.