Not able to register images in openstack

Asked by santoshsas on 2012-12-14

hello Guyz new luanchpad and newbie .. To openstack . i sucessfully installed openstack with few comands on

Ubuntu 12.04 lts with 4gb ram and i5 processor . Using virtual Virtual box to run a instance of ubuntu With openstack . I am able to login to the dashboard .. However not able to register the a tiny image from http://wiki.openstack.org/RunningNova#Register_an_image.. Please help me ..

test@test-VirtualBox:~/Downloads$ uec-publish-tarball ttylinux-uec-amd64-12.1_2.6.35-22_1.tar.gz mybucket
WARNING: 'uec-publish-tarball' is now to 'cloud-publish-tarball'. Please update your tools or docs
Fri Dec 14 15:08:23 IST 2012: ====== extracting image ======
kernel : ttylinux-uec-amd64-12.1_2.6.35-22_1-vmlinuz
ramdisk: ttylinux-uec-amd64-12.1_2.6.35-22_1-initrd
image : ttylinux-uec-amd64-12.1_2.6.35-22_1.img
Fri Dec 14 15:08:24 IST 2012: ====== bundle/upload kernel ======
failed to bundle kernel ttylinux-uec-amd64-12.1_2.6.35-22_1-vmlinuz
failed: euca-bundle-image --destination /tmp/cloud-publish-image.uDiPYs --arch x86_64 --image /tmp/cloud-publish-image.uDiPYs/.rename.l3BuxG/ttylinux-uec-amd64-12.1_2.6.35-22_1-vmlinuz --kernel true
Environment variable: EC2_CERT not foundfailed to upload kernel

Question information

Language:
English Edit question
Status:
Answered
For:
OpenStack Compute (nova) Edit question
Assignee:
No assignee Edit question
Last query:
2012-12-14
Last reply:
2012-12-20

This question was originally filed as bug #1090286.

Sounds like a question. hence turning into one.

Tom Fifield (fifieldt) said : #2

Hi,

Those particular instructions are from a long time ago :) In this case it looks like you haven't got all the variables you need setup in your environment (hence the EC2_CERT error). You can fix this by downlolading the ec2rc.sh from the dashboard settings page.

However, I'd suggest following http://docs.openstack.org/folsom/openstack-compute/install/apt/content/uploading-to-glance.html

Can you help with this problem?

Provide an answer of your own, or ask santoshsas for more information if necessary.

To post a message you must log in.