I can't spawn an instance in Compute node

Asked by TG SASIKUMAR on 2012-12-11

Hi Team,

I can't Spawn an instance in Compute node and i couldn't see any error in /var/log/nova/nova-compute.log. But i can able to create instance from Cloud controller.

Server 1 - Cloud Controller
Server 2 - Compute node

---
T.G.Sasikumar

Question information

Language:
English Edit question
Status:
Solved
For:
OpenStack Compute (nova) Edit question
Assignee:
No assignee Edit question
Solved by:
TG SASIKUMAR
Solved:
2012-12-17
Last query:
2012-12-17
Last reply:
2012-12-16

Hi Sasikumar,

This problem is arrised because of RabbitMQ, i think..

Restart RabbitMQ service and

Restart all nova services

Then check it...

let me know its working or not..

Regards,
Rajesh kannan

TG SASIKUMAR (tgsasi) said : #2

Hi Rajesh,

thanks for replying , I can create instance in cloud controller but not in compute node.
I tried restarting RabbitMQ and all nova service. but no luck.

--------
T.G.Sasikumar

Jian Wen (wenjianhn) said : #3

To run in mulit-host mode, each compute host must run the following services:
nova-compute, nova-network, nova-api-metadata or nova-api

Reference:
http://docs.openstack.org/folsom/openstack-compute/admin/content/existing-ha-networking-options.html

TG SASIKUMAR (tgsasi) said : #4

Thanks Jian , but still instance is not spawning in Compute node , I have started the above said service but its not creating instance. In mysql i can see the below error message .

# mysql -uroot -p
# use nova;
# select * from instance_faults;

instance_uuid: 603e82b9-9147-4208-a89d-217af0fb5a96
         code: 500
      message: libvirtError
      details: Unable to read from monitor: Connection reset by peer

File "/usr/lib/python2.7/dist-packages/libvirt.py", line 581, in createWithFlags
    if ret == -1: raise libvirtError ('virDomainCreateWithFlags() failed', dom=self)

Note : This compute node have single Network interface eth0 , So ihave changed in /etc/nova/nova.conf file in compute node is --flat_interface=eth0

-------
T.G.Sasikumar

Jian Wen (wenjianhn) said : #5

Can I see the full log on http://paste.openstack.org/ ?
Maybe you need to restart libvirtd.

TG SASIKUMAR (tgsasi) said : #6

Hi Jian ,

I commented vnc configuration in /etc/nova/nova.conf in both cloud controller and compute node, Now i am able to create instance in compute node. Thanks for all your help.

Now i am facing network routing issue.
-------
T.G.Sasikumar