OpenStack Compute (Nova)

Problems setting up FlatDHCP single NIC's

Asked by M.B. on 2012-06-25

Hello everybody,

I struggle with setting up an properly running Openstack Framework. I managed to proceed quiet good with my installation and I think I am not far away from my goal having it all up and running.
I can run instances, but cannot ping or ssh them. I have read a lot of posts and mailing list posts, but cannot finally set it up correctly.

My scenario is as follows:

Cloud Controller (a virtual machine)
services running: nova-api, nova-scheduler, keystone, mysql, rabbitmq, horizon
1 NIC
ip-address: 139.2.60.249

Compute Host (physical node)
services running: nova-compute, nova-network, glance
1 NIC
ip-address: 139.2.58.41

I would like to have the virtual network 192.168.100.0/24 for the instances.

I do not know where my problem exactly is. The log of my instance comes along with

Starting network...
udhcpc (v1.18.5) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cloud-setup: checking http://169.254.169.254/2009-04-04/meta-data/instance-id
wget: can't connect to remote host (169.254.169.254): Network is unreachable

But my instance apparently did receive an ip address, because I can see 192.168.100.2 in horizon. I still cannot ping or ssh the machine although I set up and assigned the secourity group rules already.

I tried to find some information about the process for an new instance getting it's metadata and ip-address, but could not found any. It could help to analyze the problem more precisely.

As my api-service runs on the Cloud Controller I set the metadata_host property in the nova.conf-file to 139.2.60.249.

I hope anybody can help me to solve this problem.

Kind Regards

Question information

Language:
English Edit question
Status:
Expired
For:
OpenStack Compute (nova) Edit question
Assignee:
No assignee Edit question
Last query:
2012-06-28
Last reply:
2012-07-13
thomaslyod (samit-dahal) said : #1

Check if network forwarding is enabled
sudo sysctl net.ipv4.ip_forward
otherwise enable it permanently by updating the flag in /etc/sysctl.conf
this will treat your ip address as router and follow the instruction acc to openstack docs

M.B. (sailormabu) said : #2

Network forwarding is enabled already.

I do not really understand a couple of things. The problem is that something apparently goes wrong when an new instance tries to request an ip address from dnsmasq. I can see the DHCPDISCOVER commands in the syslog, but nothing happens afterwards. Why is dnsmasq not responding with the correct ip address? Do I have to configure dnsmasq? Can I check somehow whether nova-network has configured the dnsmasq correctly?

And another question for more understanding: is it right that the process of fetching an ip address in context of the virtual machines is independent from the metadata service? Because the booting virtual machine can not get through to the metadata service...

Thanks...

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.