OpenStack Compute (Nova)

nova-network never start can't start instance

Asked by Ronan Lanore on 2012-06-20

Hi,

I have got essex source from github and when start nova-network it never start.
I can't start a instance beacause of that.

error when start instance : http://paste.openstack.org/show/18650/

To launch nova-network i do:

# sudo ./bin/nova-network --flagfile=./etc/nova/nova.conf --debug
patesbin output : http://paste.openstack.org/show/18648/

To verify service is realy started i do :

# sudo nova-manage service list
Binary Host Zone Status State Updated_At
nova-compute troy nova enabled XXX 2012-06-20 12:19:32
nova-scheduler troy nova enabled XXX 2012-06-20 12:19:33
nova-consoleauth troy nova enabled XXX 2012-06-19 13:35:02
nova-network troy nova enabled XXX 2012-06-19 13:35:02
nova-cert troy nova enabled XXX 2012-06-20 12:19:33
nova-console troy nova enabled XXX 2012-06-19 13:35:02
nova-volume troy nova enabled XXX 2012-06-20 12:19:33

when i use noval-all to launch all sevice nova-network still in error state

Question information

Language:
English Edit question
Status:
Solved
For:
OpenStack Compute (nova) Edit question
Assignee:
No assignee Edit question
Solved by:
Ronan Lanore
Solved:
2012-06-20
Last query:
2012-06-20
Last reply:
2012-06-20
Vish Ishaya (vishvananda) said : #1

looks like you have a stale lockfile. Try deleting nova-iptables.lock in your source directory and then starting nova-network.

Ronan Lanore (ronan-lanore) said : #2

Problem solved. Thanks a lot