Trying to use zeroMQ, but it doesn't work.

Asked by Sippakorn Tansutthiwess on 2012-05-05

I try to use zeroMQ plug-in. However, when I created new instance, it throw errors. Could you help me to figure out what I'm done wrong? Or if you used zeroMQ before, which version and setup did you use? I can't find any full document about setup zeroMQ. I appreciate for every help.

This is my setup:
- Ubuntu 12.04 LTS
- Nova 2012.1-0ubuntu2 (the one that come with default apt-get repository)
- Glance 2012.1-0ubuntu2
- ZeroMQ 2.2.0 (installation steps from, but package from official website
- ZeroMQ plug-in from

This is my configuration files:


#nova.conf file for single node, FlatDHCP networking with keystone

#logging and other administrative





#nova database

--root_helper=sudo nova-rootwrap

        "nova": [ "obelix64" ],
        "nested": [ "obelix64" ],
        "scheduler": [ "obelix64" ],
        "network": [ "obelix64" ],
        "cert": [ "obelix64" ],
        "vsa": [ "obelix64" ],
        "compute": [ "obelix64" ],
        "volume": [ "obelix64" ],
        "zmq_replies":[ "obelix64" ],
        "test":[ "obelix64" ],
        "console":[ "obelix64" ],
        "consoleauth":[ "obelix64" ]

Note that everything deploy on single machine ip (obelix64).

I can create instance with rabbitMQ with no problem.
Then I changed rpc_backend to zmq, and it start without error. Here is log file of nova-compute.log:

However, when I create instance it throw "Instance failed network setup" by the following log:

Here is the log from nova-network.log:

When I execute nova list, it seem that instance is assigned the ip address(and scheduled to this compute), but the status is ERROR

# nova list
| ID | Name | Status | Networks |
| c0f37c59-eae2-464e-9063-69794c8b949b | natty1 | ERROR | novanet= |

Question information

English Edit question
OpenStack Compute (nova) Edit question
No assignee Edit question
Last query:
Last reply:
Russell Bryant (russellb) said : #1

I subscribed the author of the zeromq driver. Hopefully he can help you out.

Eric Windisch (ewindisch) said : #2

It would be useful to see your nova-network.log. Can you provide this?

Nova-network is either not running on 'obelix64' or has erred in sending a response. Message replies are sent to (--host), which defaults to the system's 'hostname' in Essex.

Additionally, I will update the documentation, but late in development, I made it so that IP addresses will now work. This reduces the complexity of needing working name resolution. Starting with IPs may be easier than relying on host resolution.

--ip-based configuration example--

# set to real, addressable IP for this machine

# Note that you really should only *need* scheduler and network below (in Essex)
# network is optional, depending on the network manager.
        "nested": [ "" ],
        "scheduler": [ "" ],
        "network": [ "" ],
        "cert": [ "" ],
        "compute": [ "" ],
        "volume": [ "" ],
        "console":[ "" ],
        "consoleauth":[ "" ]

Thanks Russel for forwarding it to Eric.

Hi Eric, I have pasted the link of both nova-compute and nova-network logs.
For the sake of ease of reading, I am highlighting the exact portions of the logs:

1.) nova-compute log file: ( -- at line-28 (2012-05-04 19:40:09) log reports that nova-compute makes a _multi_send() call which eventually timesout at (2012-05-04 19:40:29) , and reports an error of "Instance failed network setup"

2.) nova-network log file ( -- during the timeout period nova-network log reports only two entries which are present on lines 42 & 43

we have updated nova.conf and added a FLAG
(We also tried with IP-addresses but each time we get the same error).


Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Eric Windisch (ewindisch) said : #5

Are you running the bin/nova-zmq-rpc-receiver daemon? This is necessary to receive replies. Looking at the logs, messaging was happening, but the reply was lost.