ValueError: invalid literal for int() with base 10: 'icmp'

Asked by Vaibhav Neharkar on 2011-07-27

whever i am running command " euca-authorize -p icmp -t -1:-1 default"....I am getting following error.........

Traceback (most recent call last):
  File "/usr/bin/euca-authorize", line 185, in <module>
    main()
  File "/usr/bin/euca-authorize", line 104, in main
    from_port = to_port = int(ports[0])
ValueError: invalid literal for int() with base 10: 'icmp'

Question information

Language:
English Edit question
Status:
Answered
For:
OpenStack Compute (nova) Edit question
Assignee:
No assignee Edit question
Last query:
2011-07-27
Last reply:
2011-07-27
Vish Ishaya (vishvananda) said : #1

it should be capital p for protocol: euca-authorize -P icmp
On Jul 26, 2011, at 10:55 PM, Vaibhav Neharkar wrote:

> New question #166112 on OpenStack Compute (nova):
> https://answers.launchpad.net/nova/+question/166112
>
> whever i am running command " euca-authorize -p icmp -t -1:-1 default"....I am getting following error.........
>
> Traceback (most recent call last):
> File "/usr/bin/euca-authorize", line 185, in <module>
> main()
> File "/usr/bin/euca-authorize", line 104, in main
> from_port = to_port = int(ports[0])
> ValueError: invalid literal for int() with base 10: 'icmp'
>
>
> --
> You received this question notification because you are a member of Nova
> Core, which is an answer contact for OpenStack Compute (nova).

Vaibhav Neharkar (nvaibhavv03) said : #2

Hey thanks for replying......I corrected that....but now I am getting Error ....

Failed to connect to server <B>10.14.77.196</B></HTML>...............

I am using flat network manager......10.14.77.196 is my ip..................and this request is going to proxy server....I have set no proxy setting...then also this request is to proxy server ()..................do you know why????......

you can see my netwok setting on this link.... https://answers.launchpad.net/nova/+question/165960 .....thanks in advance.....

Can you help with this problem?

Provide an answer of your own, or ask Vaibhav Neharkar for more information if necessary.

To post a message you must log in.