how to run euca-get-ajax-console ?

Asked by Naved Ali on 2011-02-28

I am working revision number 645 and i could find euca-get-ajax-console under /nova/tools directory and from where i copied this file and placed it under /user/bin. Now i tried to run as normal euca command like this euca-get-ajax-console i-00000001 but i could recieve reply as http://127.0.0.1:8000?token=b9ee0b36-c4db-48b5-9d2b-5d15e329d93a i am not sure how can i see the console using this address. so i tried to access from my windows machine bu i was able to hit the nova-ajax-console service but was getting 500 error. Can someone help me see this ajax console?

Question information

Language:
English Edit question
Status:
Answered
For:
OpenStack Compute (nova) Edit question
Assignee:
No assignee Edit question
Last query:
2011-02-28
Last reply:
2011-02-28
Jesse Andrews (anotherjesse) said : #1

have you tried changing 127.0.0.1 to the real IP of your machine running nova-api

also ami-tty doesn't work with ajax-console :( You will need to use a full linux image.

Christian Berendt (berendt) said : #2

Have you set the flag "--ajax_console_proxy_url" in nova.conf? It has to point to your running "nova-ajax-console-proxy" service, for example "http://PROXY_HOST:8000".

And it's not right that you need a "full" linux image, you just have to enable a serial console on the image and I think you have to disable the "write serial console output into a file" entry in the libvirt.xml.template (it's activated per default in the libvirt.xml.template and there are some problems).

Also you should try a newer revision, there were some bugs in nova-ajax-console-proxy, they are fixed in the lastest revision.

Can you help with this problem?

Provide an answer of your own, or ask Naved Ali for more information if necessary.

To post a message you must log in.