euca-run-instances does not respond anything

Asked by Hisaki Ohara

When I executed euca-run-instances, I could not get any response.
I followed the instruction in with the following exceptions:
 - I see a stacktrace on 'bin/nova-manage ${NOVA_MANAGE_ARGS} vpn list' due to
  "nova.exception.NotFound: project network data has not been set"
 - For the installation of libvirt-0.7.7, I should use "./configure --with-python --without-storage-disk ",
  because ped_device_* functions are undefined references, resulting in compile error.

My base environment is Ubuntu server 10.04 x86_64 edition.

The following is the output log from nova-api:
Sun, 12 Sep 2010 10:25:50 GMT
DEBUG:boto:Method: GET
DEBUG:boto:Path: /_images/
DEBUG:boto:Headers: {'Date': 'Sun, 12 Sep 2010 10:25:50 GMT', 'Content-Length': '0', 'Authorization': 'AWS fd1bad5d-8900-4b3a-ac33-16c1e005c978:myproj:3ilCAlhDw9LCGrrJHecrQZrfy4Y=', 'User-Agent': 'Boto/1.9b (linux2)'}
DEBUG:boto:establishing HTTP connection
DEBUG:root:Going to run instances...


According to 'print' debug, it seems to be blocked at yield sentence in
line 529 of nova/endpoint/

    def _get_network_topic(self, context):
        """Retrieves the network host for a project"""
        host = network_service.get_host_for_project(
        if not host:
            host = yield,
                                    {"method": "set_network_host",
                                     "args": {"user_id":,
        defer.returnValue('%s.%s' %(FLAGS.network_topic, host))

I imagine that the lack of project network data is related with my issue.
But I don't know what is wrong in my configuration.
Is the success of "node-manage vpn list" mandatory?
If so, could anyone tell me how vpn configuration (client.ovpn.template file?) should be created?

Question information

English Edit question
OpenStack Compute (nova) Edit question
No assignee Edit question
Solved by:
Ryan Lucio
Last query:
Last reply:
Revision history for this message
Best Ryan Lucio (rlucio) said :

The directions you used are out of date.

Two things (at least) need to change:

1) All of the network args have changed. s/simple/flat/g (...the flags are all prefixed with 'flat' now, not 'simple').

2) The networking code is now contained in a separate service, nova/bin/nova-network. You need to pass it all of the network args when you start it.

You can find some other installation perspectives here:

Revision history for this message
Ryan Lucio (rlucio) said :

Oh and the error in the 'nova-manage vpn list' cmd I believe is a bug; the vpn is no longer setup by the nova-manage code IIRC.

Revision history for this message
Hisaki Ohara (hisaki) said :

Thanks a lot for your replies.
Two things your pointed out does work! I could launch instances in flat network mode.

As for 'node-manage vpn list', I agree. I don't see that the execution path of node-manage has the call of vpn creation.

Revision history for this message
Hisaki Ohara (hisaki) said :

Thanks Ryan Lucio, that solved my question.