Installation begins, but not finishes.

Asked by Dmitry Lukin on 2011-11-02

Hello!
I want to install OpenStack in single node.

Ubuntu 10.04
Conditions of README file are done.

deploy.py deploys puppetmaster, puppet and then show error.

2011-11-02 19:10:58,919 - ERROR - Error occured when executing the shell command: ssh -o StrictHostKeyChecking=no -T andy@ub00 'sudo -u root sh -c "service glance-api status"'
2011-11-02 19:10:58,920 - ERROR - Error code: 256

Really, glance doesn't install.

At first i have thought about this string
DEBUG - puppet not configured to start, please edit /etc/default/puppet to enable
but fixing of this doesn't fix th e problem

I'm really weak in puppet, but if i try to
#puppetd --verbose --waitforcert 60 --no-daemonize
notice: Starting Puppet client version 0.25.4
info: Caching catalog for HOST_FQDN
info: Applying configuration version '1320232252'
notice: Finished catalog run in 0.02 seconds

# puppetmasterd --verbose --no-daemonize
notice: Starting Puppet server version 0.25.4
info: mount[files]: allowing * access
info: access[^/catalog/([^/]+)$]: allowing 'method' find
info: access[^/catalog/([^/]+)$]: allowing $1 access
info: access[/certificate_revocation_list/ca]: allowing 'method' find
info: access[/certificate_revocation_list/ca]: allowing * access
info: access[/report]: allowing 'method' save
info: access[/report]: allowing * access
info: access[/file]: allowing * access
info: access[/certificate/ca]: adding authentication no
info: access[/certificate/ca]: allowing 'method' find
info: access[/certificate/ca]: allowing * access
info: access[/certificate/]: adding authentication no
info: access[/certificate/]: allowing 'method' find
info: access[/certificate/]: allowing * access
info: access[/certificate_request]: adding authentication no
info: access[/certificate_request]: allowing 'method' find
info: access[/certificate_request]: allowing 'method' save
info: access[/certificate_request]: allowing * access
info: access[/]: adding authentication any
info: Expiring the node cache of HOST_FQDN
info: Not using expired node for HOST_FQDN from cache; expired at Wed Nov 02 19:43:05 +0800 2011
info: Caching node for HOST_FQDN
notice: Compiled catalog for HOST_FQDN in 0.21 seconds

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
nova-deployment-tool Edit question
Assignee:
No assignee Edit question
Solved by:
Dmitry Lukin
Solved:
2011-11-03
Last query:
2011-11-03
Last reply:
Dmitry Lukin (del-c) said : #1

i tried to deploy on 10.10 maverik. All the same. Stupid error, but i can't understand how to troubleshoot.

Dmitry Lukin (del-c) said : #2

It needs to use FQDN names in all cases. Not only puppetmaster. Sorry to bother you.

Shigetoshi Yokoyama (yoko) said : #3

Sorry for late response and thank you for reporting your status. I am glad to hear that you have solved the issue. -- yoko