nova-network component prerouting to itself ? is this normal?

Asked by Hugo Kou on 2011-03-31

well
after a instance ran up , I can not ping or ssh it
FlatManager mode

I remember metadata should be route to nova-api server

nova-api server is 192.168.1.1
but I can saw prerouting on nova-network 192.168.1.2
-A PREROUTING -d 169.254.169.254/32 -p tcp -m tcp --dport 80 -j DNAT --to-destination 192.168.1.2:8773

is this the problem ?

Question information

Language:
English Edit question
Status:
Solved
For:
nova-deployment-tool Edit question
Assignee:
Shigetoshi Yokoyama Edit question
Solved by:
Shigetoshi Yokoyama
Solved:
2011-04-06
Last query:
2011-04-06
Last reply:
2011-04-06
Shigetoshi Yokoyama (yoko) said : #1

In order to confirm the error, I tried to install all in one machine,
the same error (failed to ping or ssh) occurred, so I think that besides
the setting of iptables there should be other reasons.
I have reported the error in all-in-one environment as the following bug.
https://bugs.launchpad.net/nova/+bug/746909

In addition, as to the value of network_manager, because the default
value is VlanManager, I think the VlanManager may be recommended by nova.
If it is ok in system configuration, how about trying VlanManager other
than FlatManager?

-- yoko

Hugo Kou (tonytkdk) said : #2

VlanManager
 it requires a switch that supports host-managed vlan tagging.

so I never try it.

In my successful testing environment.

Manually:
Success.............All in one <Flat><FlatDHCP>
Success.............One machine include all nova service and two nova-compute <FlatDHCP>

btw, in nova.conf ,
--fixed_range=192.168.2.64/26

during testing process...the instance ip is 10.0.0.x ???
I don't understand , bcz in my experience , instance's ip should be 192.168.2.64/26 segment. am I right?
how come instance's ip assign to 10.0.0.x ?
I remember 10.0.0.x is default. Is that means --fixed_range is not work?

Hugo Kou (tonytkdk) said : #3

I'm not sure if my consideration is correct.

I check setup-network.sh , I saw it create network for project is 10.0.0.0/8 3 16

I always set project network is inside fixed_range....192.168.2.64/26

is there any tricky stuff ?

Best Shigetoshi Yokoyama (yoko) said : #4

Did you succeed to ping and ssh when network manager is Flat?
And if you succeeded, could you tell me how do you install it?

Yes, you are right. According to "Configuring OpenStack Compute -
Basics(http://docs.openstack.org/openstack-compute/admin/content
/ch03s03.html#d5e257)", the IP addresses specified in command
"nova-manage network create" should be included in the values of
fixed_range.

Therefore, as what you said, the fixed_range should be changed to
10.0.0.0/8.

And if you want to change it to another value, the fixed_range and
setup-network.sh should be changed together.

As to the next version for Cactus, we shall move the IP addresses in
setup-network.sh to some config file.

-- yoko

Hugo Kou (tonytkdk) said : #5

Thanks Shigetoshi Yokoyama, that solved my question.