Banshee "Now playing" notifications should replace any previous "Now playing" message, whose bug is it?

Asked by Jeroen Hoek on 2009-09-29

In Ubuntu Karmic alpha 6, the development version of Banshee (1.5.0) uses Notify-OSD to display a "Now playing" notification with the artist and track title of the song that has just started playing. When skipping that song before the notification disappears, the next "Now playing" notification doesn't show up until it is predecessor is gone instead of at the start of the song. When I skip three songs, it takes quite a while for all those notifications to be shown in succession!

This is a user experience bug I suppose, and I want to file it, but whose bug is it? Should Banshee be calling Notify-OSD in some way that it replaces any previous "Now playing" notification (if present), or is Notify-OSD lacking the functionality to replace a previous notification immediately?

Question information

Language:
English Edit question
Status:
Solved
For:
Notify OSD Edit question
Assignee:
No assignee Edit question
Solved by:
Mirco Müller
Solved:
2009-09-29
Last query:
2009-09-29
Last reply:
2009-09-29
Best Mirco Müller (macslow) said : #1

That's a bug within banshee then. notify-osd provides the ability to immediately replace the content of an existing notification-bubble. In notify-osd's source tree there's even a C#-example demonstrating how to do that (notify-osd/examples/update-notifications.cs).

Jeroen Hoek (mail-jeroenhoek) said : #2

Thanks Mirco Müller, that solved my question.

This was working fine with Banshee from git in Jaunty, but I also noticed this when I installed Karmic. While the bug could still be Banshee's fault, it seems like something changed in Notify-OSD that caused this.

Well, this [1] seems to be the relevant report on Launchpad. Was I wrong to think that this wasn't an issue using Banshee + Notify-osd in Jaunty?

[1] https://bugs.launchpad.net/banshee/+bug/334809

Anakin Starkiller (sunrider) said : #5

I have the exact same problem with Panflute (Gnome music applet) but everything works fine with rhythmbox...
So this is definitely a player issue ;)

Ryan Fugger (rfugger) said : #6

I have the same problem with network manager -- when I resume from standby, it right away tells me my network is disconnected, but that notification persists for 15 seconds before the "connected" notification pops up, even though it reconnects within a second or two. I've filed a bug with network manager:

https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/460964