I've tried various linux distros but I've always had problems sharing files and printers with samba. Does NitroShare set up sharing a printer attached to a W7 PC with a Linux PC?

Asked by silver16 on 2014-08-13

My current set up consists of a cabled Windows 7 desktop with a Canon MP600 inkjet attached, another cabled W7 desktop, a W7 wireless-connected laptop and a cabled fileserver (using a Linux OS?) all connected via a router to the Internet over an ADSL2 landline. Presently, they all work together successfully. However, from time to time over the years I've tried unsuccessfully to add an ageing Linux laptop (cabled or wireless - makes no difference) to this LAN - SAMBA sucked everytime, but with a different problem with each distro! Can NitroShare, at last, do the business? If 'yes' then I intend to install, perhaps, Linux Lite on the former, Win XP aging laptop and hope to share files and the printer over my LAN. Many thanks for your help.

Question information

Language:
English Edit question
Status:
Solved
For:
NitroShare Edit question
Assignee:
No assignee Edit question
Solved by:
Nathan Osman
Solved:
2014-08-15
Last query:
2014-08-15
Last reply:
2014-08-14
Best Nathan Osman (george-edison55) said : #1

NitroShare makes it very easy to transfer files from one machine to another over a local network. Windows XP and 7 are both supported with the current release (0.2).

You can also install NitroShare on Linux, although it may need to be compiled from source if it is not already packaged for your distro. My suggestion would be to try running NitroShare on XP first and if that doesn't work well, then switch to a lightweight Linux distro. Arch Linux is a good choice since a compiled version already exists in the AUR (Arch User Repository).

Unfortunately, NitroShare doesn't currently do anything with printers, you will need to either continue using Samba or switch to another network protocol for printing.

One small caveat - NitroShare currently has a bug that prevents really large files from being transferred. (Files larger than about 500 MB can be a problem.) I am currently working on a fix for this.

Please let me know if you have any more questions.

silver16 (roduffy2000) said : #2

Thank you for your prompt response to my question.

Yes, you have solved my problem!