Installing on ubuntu 12.04 & 12.10

Asked by NiKoyes on 2012-11-05

I ask a question that has benn already asked, but : the repositry doesn't work !

I get the following error :

Ign stable Release
E: Erreur de GPG : stable Release : Les signatures suivantes ne sont pas valables : NODATA 1 NODATA 2

I didn't abandonned like that, i tried the compilation way, after installing fastdb and its windows-formated configure file, ... etc
 at last i got the following error :

/usr/include/boost/container/map.hpp:147:1: erreur: invalid application of ‘sizeof’ to incomplete type ‘boost::STATIC_ASSERTION_FAILURE<false>’
make[4]: *** [nshade_shared_memory.lo] Erreur 1

during the configure, there was the following warning :

checking for the toolset name used by Boost for g++... configure: WARNING: could not figure out which toolset name to use for g++

but it went on...

What's the hell ?

Question information

English Edit question
Nightshade Legacy Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Best Trystan (trystan) said : #1

You encountered an error that occurs on systems using more recent versions of boost. I 'just' fixed this. So, you'll need to do a fresh pull of the source from launchpad to compile successfully.

Thanks Trystan, that solved my question.

Tomasz Lewicki (stalkerpl) said : #3

I get same error.

I was trying with boost 1.49 and 1.53 (UBuntu 13.04). FastDB versions I tried were 3.65, 3.69, 3.70, 3.73 (latest). I have latest Nightshade 11.12.1 tarball with verified MD5 sum. Configure phase of NS was succesful except of error cited by NiKoyes; make phase end with same error cited above.

What can/should I do next?

Trystan (trystan) said : #4

Same as above. You'll need to build from trunk rather than the tarball. So, that means installing bzr and pulling the source from launchpad.

Tomasz Lewicki (stalkerpl) said : #5

But doesn't 'trunk' mean Nighshade NG branch...?

Trystan (trystan) said : #6

No, NG is on a completely different repository. It is not a fork of the Nightshade 'Legacy' code.

We've continued to make some minor fixes to Nightshade Legacy on during NG development, but we don't post a new tarball regularly.

Tomasz Lewicki (stalkerpl) said : #7

OK, thank you, Trystan. I'll pull the source from Bazaar then.

Tomasz Lewicki (stalkerpl) said : #8

I have downloaded current source and succesfully builded Nightshade - except translations. They are not seen during compilation process and thus not installed in /usr/local/share/locale - how to push it further? Besides Polish translation is not updated for about 1,5 year. In "Translations" tab I see message "Nightshade Legacy does not translate its messages". Does it mean current translations will stay forever and I should use my changes only in my local copy? There is stupid mistake (done by me BTW) and I want to correct it for all community, if possible.

If you do a "make install" the translations should be installed.

I'll see about getting translations working on Launchpad again.


Tomasz Lewicki (stalkerpl) said : #10

During last stage of "make install" phase I see messages similar to these:

make[1]: Entering directory `/home/stalker/nightshade-11.14.2/po'
/bin/sh .././mkinstalldirs /usr/local/share
/usr/bin/install: could not stat on „./”: No such file or directory
installing ./ as /usr/local/share/locale/af/LC_MESSAGES/
/usr/bin/install: could not stat on „./”: No such file or directory
installing ./ as /usr/local/share/locale/ar/LC_MESSAGES/
/usr/bin/install: could not stat on „./”: No such file or directory

And so on until last language (zh_TW).