No Textures in Mac

Asked by Jim Greenhouse on 2011-11-12

I was able to get Nightshade to run on my MacBook using OS 10.7.2. I have two problems: I can't turn off the atmosphere and there are no texture maps on any planets or moons. Can anyone tell me how to solve this problem?

Question information

Language:
English Edit question
Status:
Answered
For:
Nightshade Legacy Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-17
Last reply:
2011-11-17
Trystan (trystan) said : #1

Can you provide a little more information about this Mac? I.e. generation/model ID (you can find this on the wikipedia page for MacBooks).

How are you toggling atmosphere? Via the button or 'a' key?

I can't reproduce either issue on my Macbook Pro 8,1 (also running 10.7.2).

Jim Greenhouse (stardude67-n) said : #2

This is a mid 2007 13-inch MacBook 2,1 with a 2.16 GHz Intel Core 2 Dup processor, 2.5 GB of memory, and GMA 950 64 MB graphics. I tried toggling the atmosphere with both the A key and icon. Neither did anything. I also tried turning off the atmosphere in the settings.

Trystan (trystan) said : #3

Shaders may be causing problems with OpenGL state on that hardware. Try adding 'flag_shaders = false' under the [Rendering] section of ~/.nightshade/config.ini.

Jim Greenhouse (stardude67-n) said : #4

I tried that and also tried turning off the atmosphere while I was in the config file. There was no change. Thanks anyway for the suggestion.

Trystan (trystan) said : #5

Unfortunately, it may simply not work on the old GMA 950s. I've tested it on the Intel GMA X3100 (starting on Macbook 3,1) and the Intel HD 3000 (latest gen MacBooks). Both of those configurations work. The intel video chipsets are pretty hit and miss.

Can you help with this problem?

Provide an answer of your own, or ask Jim Greenhouse for more information if necessary.

To post a message you must log in.