Nightshade won't launch after reinstall

Asked by chemed on 2011-05-20

I had do delete the version of Nightshade that I ran through macports. I thought I would just reinstall the new version using the mpckg file. Now, when I try to run nightshade, I get the following error message>

 Nightshade 11.2.1 - Community Edition
[ Copyright (C) 2003-2011 Digitalis Education Solutions, Inc. et al.
[ Copyright (C) 2000-2008 Faien Chereau et al.

LOCALE DIRECTORY: /opt/local/share/locale
CONFIG DIR: /Users/McBride/.nightshade/
Attempting to use an existing older config file.
Warning: Couldn't set 1920x1200 video mode (No video mode large enough for 1920x1200), retrying with stencil size 0
Error: Couldn't set 1920x1200 video mode: No video mode large enough for 1920x1200!

What's going on? How to fix?


Question information

English Edit question
Nightshade Legacy Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Trystan (trystan) said : #1

Did you set the resolution to 1920x1200? Sounds like maybe the config file was overwritten on the reinstall...

Try editing .nightshade/config.ini and set a lower resolution; 1024x768 is always a good starting point. Then you can always set it back higher from the configuration options in the app or via the config.ini.

chemed (amcbride) said : #2

this may sound like a dumb question but...

How do I open the config file?

Best Trystan (trystan) said : #3

Any standard text editor will do. I just use nano in a terminal. E.g. nano /Users/trystan/.nightshade/config.ini

chemed (amcbride) said : #4

thanks, I didn't know about "nano".
According to the config file, I'm still running version 10.2.1 that I built from the binary package using macports. I thought I had deleted all of the files from that version. I recently downloaded version 11.7.1 (zip) for intel mac pkg file and ran the install. Shouldn't my version be updated?

within the config file, how do I edit the resolution numbers and how do I change the projection type to "mirror"?

thanks for all the help.

chemed (amcbride) said : #5


I was able to change the screen resolution from the config file and run nightshade. I changed the projection type within the program but it sets the horizon way too high for my system. Is there a way to edit this?

chemed (amcbride) said : #6

Also, version is updated to 11.7.1

chemed (amcbride) said : #7

ok, last question.

What are the units of the mirror calibration section in the config file? Are they in meters?

chemed (amcbride) said : #8

Thanks Trystan, that solved my question.