Problems during 'make' on Kubuntu 10.10

Asked by Tomasz Lewicki on 2011-04-20

When doing 'make' stage on Kubuntu 10.10 (64-bit version) I get such errors:

audio.cpp:167: error: ‘Mix_LoadMUS’ was not declared in this scope
audio.cpp: In destructor ‘virtual Audio::~Audio()’:
audio.cpp:183: error: ‘Mix_FreeMusic’ was not declared in this scope

What should I install to do 'make' successfully?

Question information

English Edit question
Nightshade Legacy Edit question
No assignee Edit question
Solved by:
Tomasz Lewicki
Last query:
Last reply:
Trystan (trystan) said : #1

Those are declared in the SDL_Mixer library headers. Make sure you have the development or 'dev' package installed for SDL_Mixer. Since configure succeeded, I'm guessing you just have the SDL_Mixer binaries installed without the headers.

Tomasz Lewicki (stalkerpl) said : #2

I have installed libsdl-mixer1.2-dev package but no luck - still the same error.

Tomasz Lewicki (stalkerpl) said : #3

I suspected FastDB library and was right - after recompiling it and installing again I could do 'configure', 'make' and 'make install' with Nightshade smoothly. But when I tried to run NS I got error 'nightshade: error while loading shared libraries: cannot open shared object file: No such file or directory'. Looked back into my previous questions on this list and found solution - running 'ldconfig' and then trying to run NS again. Now it is working.

Thanks, Trystan!