won't display on HDMI projector

Asked by Jim Havens on 2011-03-27

Win 7 Home Premium 64bit; Dell XPS-L501X w/Intel i5; 6GB RAM; NVIDIA GeForce GT420M 1GB; latest drivers for all.
Nightshade runs fine on laptop display (warped fisheye). When switching to HDMI projector, nothing but white screen. Disabling Aero makes no difference. Same when starting Nightshade while desktop is being displayed on projector. Any ideas? Tried posting bug but wouldn't accept my summary.

Question information

English Edit question
Nightshade Legacy Edit question
No assignee Edit question
Solved by:
Jim Havens
Last query:
Last reply:
Trystan (trystan) said : #1

Verify that the resolution Nightshade is configured to run at is supported by your projector. If your desktop displays properly on the projector, you can configure Nightshade to run at that resolution via the config.ini file in the Nightshade section of the Start menu.

Jim Havens (havensjh) said : #2

Trystan, thanks for quick reply. Yes, the Nightshade resolution is set the same as laptop display. I double-checked in config.ini and it shows 1920w x 1080h. As you might expect, Stellarium has the same issue. All other software works fine with projector.

Trystan (trystan) said : #3

How do you have the two displays configured? That is, does the projector mirror your laptop display, extend the display, or does the laptop screen go blank when switching to the projector?

Make sure the projector is configured as the primary display rather than a secondary (i.e. display 1 in screen resolution settings).

Jim Havens (havensjh) said : #4

I select "Projector Only" (projector becomes main display) and the laptop does go blank.

When checking screen resolution while Projector Only, Win 7 reports that the projector is the #2 display but that it is the primary and that the desktop is being shown only on the primary.

FWIW, Stellarium does show an image of the sky but does not respond to any keys. CTL Q does close the program OK.

Nightshade never shows any image just a dark screen. CTL Q closes it OK also.

Jim Havens (havensjh) said : #5

Solved! NVIDIA just released new drivers. Installed them and everything works fine. As a reminder, this was a Dell XPS laptop with NVIDIA GeForce GT 420M graphics adapter. Thanks for your time looking into this issue.