ppa php5 and php5.3 404 no found

Asked by Philippe Blanc on 2012-03-06

both ppa for php5 and php5.3 return a 404 no found

Failed to fetch http://ppa.launchpad.net/nginx/php5/ubuntu/dists/oneiric/main/binary-i386/Packages 404 Not Found
and
Failed to fetch http://ppa.launchpad.net/nginx/php5.3/ubuntu/dists/oneiric/main/binary-i386/Packages 404 Not Found

Are you still planning to publish these two ppa?

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Nginx Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Jesús García Crespo (sevein) said :
#1

yeah, missing that too much!

Revision history for this message
Zack Gilman (gilman31) said :
#2

Yes, please let us know what the deal is here.

Revision history for this message
Brian Mercer (brianmercer) said :
#3

I sent an email to Michael Lustfield and he responded that they do not intend to maintain a php5 backport going forward.

For now I made one of my own for oneiric, based on the precise package: https://launchpad.net/~brianmercer/+archive/php5

Precise should be out in a couple months and Debian Sid is already at 5.4: http://packages.debian.org/sid/php5

I haven't tested 5.4 with Drupal so I don't know if there's any problems there.

What other options do we have?

Revision history for this message
Brian Mercer (brianmercer) said :
#4

Ondřej Surý is a maintainer of the Debian php5 package and has a ppa at: https://launchpad.net/~ondrej/+archive/php5

However he has 5.4 up there now which may introduce new problems with existing code.

Revision history for this message
magu (rafael-magu) said :
#5

Has anyone been able to find one for Lucid? Precise is not out yet and I have all the app servers in our clusters running the PPA from Nginx at 5.3.10. A new deployment of 2 more app servers came with 5.3.2 instead, and that's causing issues (there's a segfault bug that affects us).

Revision history for this message
Ashok Modi (btmash-z) said :
#6

It seems that brianmercer has it own in his repo at https://launchpad.net/~brianmercer/+archive/php5. Its certainly been very confusing on what is happening and an announcement for it being unsupported for a while (and them removing the repo) would have been better than how it all got handled :(

Revision history for this message
Brian Mercer (brianmercer) said :
#7

I uploaded an oneiric package two days ago and I'm using it myself. I uploaded a second attempt at a lucid package today and it seems to run fine but could use some testing. (first attempt from yesterday didn't load php-fpm)

The whole launchpad ppa system could use some improvements. Like a way to subscribe to notices for a ppa so ppa maintainers could contact people using their ppa. Also a way to search for a version of a package would be nice since searching all ppas for "php5" and then having to check each of 50 different packages to find them all out of date is annoying.

Revision history for this message
magu (rafael-magu) said :
#8

At this stage, I'm waiting on our internal devs to finish fixing a bug before updating the dev environment to 5.4 using ondrej's PPA repo. And then we'll be testing that out to see what works.

Agree with Brian. A way to subscribe to notices would be great.

Revision history for this message
Brian Mercer (brianmercer) said :
#9

I started to install ondrej's PPA for testing, but it uses a newer phpapi-2010xxxx version for plugins, so all the Ubuntu plugin packages that I use on lucid through oneiric, i.e. php-apc, php5-xprof, php-memcached, phpredis, which are all built against phpapi-2009xxxx, won't install on their own.

Trying to force them or installing them all from PECL/source is too much hassle for today.

I did send ondrej a message about it.

Revision history for this message
magu (rafael-magu) said :
#10

Good to know. I'll test out your 5.3.10 package.

Revision history for this message
Ed Tiller (tillere) said :
#11

Brian,
I tested the Lucid package today and am getting a php5-fpm error (won't load). Thank you for working on this. Error message follows:
Preparing to replace php5-fpm 5.3.5-1ubuntu7.2ppa1~lucid (using .../php5-fpm_5.3.10-1ubuntu1ppa1~lucid_amd64.deb) ...
 * Stopping PHP5 FPM...
   ...done.
/var/lib/dpkg/tmp.ci/preinst: 7: dpkg-maintscript-helper: not found
dpkg: error processing /var/cache/apt/archives/php5-fpm_5.3.10-1ubuntu1ppa1~lucid_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 127
update-rc.d: warning: php5-fpm stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (none)
 * Starting PHP5 FPM...
Mar 08 15:07:49.744442 [WARNING] [pool www] pm.start_servers is not set. It's been set to 20.
   ...done.
Errors were encountered while processing:
 /var/cache/apt/archives/php5-fpm_5.3.10-1ubuntu1ppa1~lucid_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

Revision history for this message
Brian Mercer (brianmercer) said :
#12

I could have sworn that I fixed this with my second upload.

If you check out ondrej's ppa he just uploaded a new dpkg-maintscript-helper package for the lucid package to solve this issue. His patch against 5.4 didn't apply against the precise 5.3.10 package though. I'll have to take a closer look at his solution.

Not sure why the i386 package loads but you're the second person to get a failure from the amd64 package.

Revision history for this message
Brian Mercer (brianmercer) said :
#13

Using that helper package as is won't help us because it includes:

Breaks: php5-common (<= 5.4.0-3~)

Revision history for this message
magu (rafael-magu) said :
#14

Problem is I can't add Ondrej's PPA to get dpkg-maintscript-helper because it will also update PHP to 5.4.

Revision history for this message
Brian Mercer (brianmercer) said :
#15

OK grabbed Ondrej's dpkg-maintscript-helper package, changed the Breaks: php5-common (<= 5.4.0-3~) to Breaks: php5-common (<= 5.3.10) and uploaded to Launchpad.

Give it a while to build and then we can test.

dpkg-maintscript-helper is not a dependency of the php5 package so you'll have to install it first until I reroll the php5 package.

Revision history for this message
magu (rafael-magu) said :
#16

As it turns out, 5.4 won't install for me because of the following:

The following packages have unmet dependencies:
  php5-xapian: Depends: phpapi-20090626 which is a virtual package.
  php5-xdebug: Depends: phpapi-20090626 which is a virtual package.
  php-apc: Depends: phpapi-20090626 which is a virtual package.
  php5-suhosin: Depends: phpapi-20090626 which is a virtual package.
The following actions will resolve these dependencies:

Remove the following packages:
php-apc
php5-suhosin
php5-xapian
php5-xdebug

As you can tell, the four packages above are important to us, so we can't use this back ported metapackage yet. Gonna try Brian's dpkg-maintscript-helper package now.

Revision history for this message
magu (rafael-magu) said :
#17

Brian, did you request an amd64 build as well? I only see i386 ones on the Builds page: https://launchpad.net/~brianmercer/+archive/php5/+builds

Revision history for this message
magu (rafael-magu) said :
#18

Brian, did you request an amd64 build as well? I only see i386 ones on the Builds page: https://launchpad.net/~brianmercer/+archive/php5/+builds

Revision history for this message
Brian Mercer (brianmercer) said :
#19

It's not a binary, so only one package. Dunno how long til Launchpad gets around to building it. I just uploaded it to:

http://www.brianmercer.com/files/dpkg-maintscript-helper_1.15.7.4ppa2~lucid_all.deb

if you wanna download and install with

dpkg -i dpkg-maintscript-helper_1.15.7.4ppa2~lucid_all.deb

I was about to do it also. Thanks.

Revision history for this message
magu (rafael-magu) said :
#20

Tried it now, but got this:

Preparing to replace php5-fpm 5.3.2-1ubuntu4.7ppa5~lucid1 (using .../php5-fpm_5.3.10-1ubuntu1ppa1~lucid_amd64.deb) ...
dpkg-maintscript-helper: error: environment variable DPKG_MAINTSCRIPT_NAME is required
dpkg: error processing /var/cache/apt/archives/php5-fpm_5.3.10-1ubuntu1ppa1~lucid_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
dpkg-maintscript-helper: error: environment variable DPKG_MAINTSCRIPT_NAME is required
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/php5-fpm_5.3.10-1ubuntu1ppa1~lucid_amd64.deb

What should the environment variable be set to?

Revision history for this message
Brian Mercer (brianmercer) said :
#21

Nope. Just tried it and it requires an environment variable. Still a work in progress.

Revision history for this message
magu (rafael-magu) said :
#22

Got it:

export DPKG_MAINTSCRIPT_NAME=php5-fpm

All good now!

Revision history for this message
Brian Mercer (brianmercer) said :
#23

Super thanks. I'll work it into the package.

Revision history for this message
Zack Gilman (gilman31) said :
#24

Can you please move your bugs/issues with other builds to your respective channels? This should remain open only for communication with this developer.

Revision history for this message
magu (rafael-magu) said :
#25

Apologies for the inconvenience, Zack. We are merely providing a way for Lucid and Oneiric users to install PHP 5.3.10 since the maintainers of this PPA removed their port from public access. So even though some of the messages on this thread may not be targeted at the devs themselves, I believe their content is of importance to the people subscribed to this question (including the OP).

But again: apologies for deviating from (and then coming back to) the original issue. :)

Revision history for this message
Thomas Ward (teward) said :
#26

The NGINX PPA for PHP is no longer supported, and has been removed from public access.

While helping others with getting some version of PHP onto their system is helpful, it does not answer this question.

The first poster of an answer has it correct, the PPA is no longer supported.

Marked as "Solved"