enable to perform any active functions

Asked by Zhuo on 2016-08-10

I am using adafruit's pn532 board connected to Raspberry pi for my project. The read card function seems work well. But when I tryout the emulate and work as peer function on the 'get start' section, none of these works.

Here is the code I tried to run:

clf = nfc.ContactlessFrontend('ttyAMA0:pn532')
sensf_res = bytearray.fromhex('01 03FEFFE011223344 01E0000000FFFF00 12FC')
def on_startup(target):
    target.brty = "212F"
    target.sensf_res = sensf_res
    return target
clf.connect(card={'on-startup': on_startup})

After I run the code, it just stucked there and when I tried to read it with my Nexus 5X with NXP taginfo App, neigher of the python program or the app respond to it. I even tried to use an other NFC borad to read it, but it still doesn't work.

Really need help here. Have been stucked for a long time.

Question information

Language:
English Edit question
Status:
Answered
For:
nfcpy Edit question
Assignee:
No assignee Edit question
Last query:
2016-08-10
Last reply:
2016-08-29
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

I can confirm that Type 3 Rag Emulation is currently not working with PN532 (and PN533). It looks like the chip requires an RF_settings command for Type A parameters (quite strange) to set the same RF values that are already active (even more strange). I'll have to test a bit more and will then update the master version on GitHub (note that nfcpy is no longer hosted on Lauchpad but at https://github.com/nfcpy/).

This is now fixed on github master.

Can you help with this problem?

Provide an answer of your own, or ask Zhuo for more information if necessary.

To post a message you must log in.