How can I emulate a Type1 tag with RC-S380

Asked by fengzhiquan

I found the following code in the rcs380.py :

        if target.rid_res:
            info = "listening for type 1 tag activation is not supported"
            raise nfc.clf.UnsupportedTargetError(info)

Is that means the reader can not response rid command and not support to emulate a t1t?

Question information

Language:
English Edit question
Status:
Solved
For:
nfcpy Edit question
Assignee:
No assignee Edit question
Solved by:
Stephen Tiedemann
Solved:
Last query:
Last reply:
Revision history for this message
Best Stephen Tiedemann (stephen-tiedemann) said :
#1

More than that. Type 1 Tag emulation is not possible with *any* of the known desktop readers, simply because T1T commands are sent as separate Type A frames per byte, receiving them would need control of the µC firmware. Interestingly it's different for T1T responses, they come as all bytes in one frame.

Revision history for this message
fengzhiquan (fengzhiquan) said :
#2

Thanks Stephen Tiedemann, that solved my question.