No reader found (ACR122U, OS X Yosemite)

Asked by Alexandre Cisneiros on 2015-02-09

Hello. I'm trying to setup nfcpy on my machine (Mac OS X Yosemite).

I've connected an ACR122U reader via USB. The red LED is On and, if I touch a card, the reader beeps and the LED turns yellow. I, however, cannot get nfcpy to work with it.

$ python examples/tagtool.py -d nfc.dev
[main] enable debug output for module 'nfc.dev'
[nfc.clf] searching for reader with path 'usb'
[nfc.dev.transport] using pyusb version 1.x
[nfc.dev.transport] path matches '^(usb|)$'
[nfc.dev] trying usb:072f:2200
[nfc.dev] import nfc.dev.acr122
[nfc.clf] no reader found at 'usb'
[main] no contactless reader found

I have installed libusb and pyusb. I've tried using the default drivers as well as installing the ones from ACS website.
I've tried searching all over the internet, but cannot find a solution to get me past this point.

Thanks in advance to anyone who can help me!
Alexandre.

Question information

Language:
English Edit question
Status:
Answered
For:
nfcpy Edit question
Assignee:
No assignee Edit question
Last query:
2015-02-12
Last reply:
2015-02-13

It could that some other process is using the reader, for example the PC/SC daemon. Or that the hardware is not accessible from an ordinary user account - try as superuser to find out. If it is a permission problem, then you could check if the note in https://nfcpy.readthedocs.org/en/latest/topics/get-started.html#installation can be applied on OS X.

Generally speaking, nfcpy does not require any specific driver for the ACR122, it just talks directly with the contacless chip through the USB-CCID interface that an ACR122 presents.

I've tried super user as well. The fact that the light on the reader is on and that if I touch a tag it beeps makes me think there is some process using the reader.

I tried killing the pcsc process, but nothing changes. Is there a way of knowing which process may be using the reader? I have no idea how to find that out on OS X.

On a side note: `pcsctest` works. Don't know if that is relevant.

If pcsctest works then almost certainly there is pcscd running. What works on my Ubuntu is to learn which processes use USB device files by "sudo lsof | grep "/dev/bus/usb/". Maybe that also works on OS X but I can't proof.

Can you help with this problem?

Provide an answer of your own, or ask Alexandre Cisneiros for more information if necessary.

To post a message you must log in.