ubuntu error installing quantum-plugin-openvswitch-agent: apt-get install : Failed to fetch http://ppa.launchpad.net/openstack-ubuntu-testing/folsom-deps-staging/ubuntu/pool/main/p/python-cliff/python-cliff_1.1.2-0ubuntu2~cloud0_all.deb Size mismat

Asked by Krishna Kothapalli on 2012-10-02

Trying to follow steps from http://docs.openstack.org/trunk/openstack-network/admin/content/install_quantum_agent_ovs.html and hit the below error. Any alternative way to install ?

apt-get -y install quantum-plugin-openvswitch-agent

root@ubantu:/home/krishna/quantum-2012.2/bin# apt-get -y --force-yes install quantum-plugin-openvswitch-agent
< -y --force-yes install quantum-plugin-openvswitch-agent
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  dkms libjs-sphinxdoc libjs-underscore libyaml-0-2 openvswitch-common
  openvswitch-datapath-dkms openvswitch-switch python-amqplib python-anyjson
  python-cliff python-cmd2 python-decorator python-eventlet python-gflags
  python-greenlet python-iso8601 python-keystone python-keystoneclient
  python-kombu python-migrate python-netaddr python-passlib python-prettytable
  python-pyparsing python-pyudev python-quantum python-quantumclient
  python-routes python-sqlalchemy python-sqlalchemy-ext python-tempita
  python-yaml quantum-common quantum-plugin-openvswitch
Suggested packages:
  javascript-common python-amqplib-doc python-greenlet-dbg python-greenlet-dev
  python-greenlet-doc python-memcache python-boto python-couchdb
  python-kombu-doc python-pymongo ipython python-qt4 python-pyside.qtcore
  python-sqlalchemy-doc python-psycopg2 python-kinterbasdb python-pymssql
The following NEW packages will be installed:
  dkms libjs-sphinxdoc libjs-underscore libyaml-0-2 openvswitch-common
  openvswitch-datapath-dkms openvswitch-switch python-amqplib python-anyjson
  python-cliff python-cmd2 python-decorator python-eventlet python-gflags
  python-greenlet python-iso8601 python-keystone python-keystoneclient
  python-kombu python-migrate python-netaddr python-passlib python-prettytable
  python-pyparsing python-pyudev python-quantum python-quantumclient
  python-routes python-sqlalchemy python-sqlalchemy-ext python-tempita
  python-yaml quantum-common quantum-plugin-openvswitch
  quantum-plugin-openvswitch-agent
0 upgraded, 35 newly installed, 0 to remove and 12 not upgraded.
Need to get 503 kB/8,051 kB of archives.
After this operation, 38.8 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  libyaml-0-2 dkms libjs-underscore python-amqplib python-anyjson python-cmd2
  python-decorator python-greenlet python-eventlet python-gflags python-kombu
  python-tempita python-migrate python-netaddr python-pyparsing python-pyudev
  python-iso8601 python-routes python-passlib python-yaml
Get:1 http://ppa.launchpad.net/openstack-ubuntu-testing/folsom-deps-staging/ubuntu/ precise/main python-sqlalchemy all 0.7.8-1ubuntu1~cloud0 [475 kB]
Get:2 http://ppa.launchpad.net/openstack-ubuntu-testing/folsom-deps-staging/ubuntu/ precise/main python-cliff all 1.1.2-0ubuntu2~cloud0 [13.0 kB]
Get:3 http://ppa.launchpad.net/openstack-ubuntu-testing/folsom-deps-staging/ubuntu/ precise/main python-sqlalchemy-ext i386 0.7.8-1ubuntu1~cloud0 [14.2 kB]
Fetched 582 kB in 1s (379 kB/s)
Failed to fetch http://ppa.launchpad.net/openstack-ubuntu-testing/folsom-deps-staging/ubuntu/pool/main/s/sqlalchemy/python-sqlalchemy_0.7.8-1ubuntu1~cloud0_all.deb Size misma\
tch
Failed to fetch http://ppa.launchpad.net/openstack-ubuntu-testing/folsom-deps-staging/ubuntu/pool/main/p/python-cliff/python-cliff_1.1.2-0ubuntu2~cloud0_all.deb Size mismatch
Failed to fetch http://ppa.launchpad.net/openstack-ubuntu-testing/folsom-deps-staging/ubuntu/pool/main/s/sqlalchemy/python-sqlalchemy-ext_0.7.8-1ubuntu1~cloud0_i386.deb Size \
mismatch
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
root@ubantu:/home/krishna/quantum-2012.2/bin#
-m=-U:**--F1 ubuntu Bot (15675,46) (Shell:run)--11:33AM-------------

Question information

Language:
English Edit question
Status:
Answered
For:
neutron Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-02
Last reply:
2012-10-02
Adam Gandelman (gandelman-a) said : #1

This looks more like a transient network error than anything else. Ensure that you've run 'apt-get update' recently and make sure there are no transparent proxies between you and there that may be causing issues

Thanks Adam for the suggestion.
I have a http_proxy . wondering if there is any workaround.

Otherwise I'll use another machine with not any proxy.

Can you help with this problem?

Provide an answer of your own, or ask Krishna Kothapalli for more information if necessary.

To post a message you must log in.