quantum-2012.1~e2 ImportError: No module named server

Asked by Itzik B. on 2012-01-05

After installing using the following commands:

# tar zxvf quantum-2012.1~e2.tar.gz
# cd quantum-2012.1~e2.
# pip install -r tools/pip-requires
# python setup.py install
# quantum-server

I get the following error:

Traceback (most recent call last):
  File "/usr/local/bin/quantum-server", line 9, in <module>
    load_entry_point('quantum-server==2012.1dev', 'console_scripts', 'quantum-server')()
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources.py", line 337, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources.py", line 2279, in load_entry_point
    return ep.load()
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources.py", line 1989, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
ImportError: No module named server

Question information

Language:
English Edit question
Status:
Solved
For:
neutron Edit question
Assignee:
No assignee Edit question
Solved by:
Itzik B.
Solved:
2012-01-12
Last query:
2012-01-12
Last reply:
2012-01-11
Brad Hall (bgh) said : #1

There is definitely a bug in the current setup.py -- this will be replaced pretty soon (there is a change in code review right now to move us to a real setup.py). In the meantime, you can work around this by doing the following:

for x in client server common; do python setup_${x}.py build; done
python setup.py install

Then run quantum-server

Deepak Garg (deepak.garg) said : #2

I have got the same error. Waiting for the fix. Thanks

dan wendlandt (danwent) said : #3

Hi deepak. Does brad's work around not work for you?

Deepak Garg (deepak.garg) said : #4

HI Dan, I didn't try Brad's work-around.
I then tried a fresh setup uisng QuantumDevstack but again landed up in a similar error:
https://answers.launchpad.net/quantum/+question/184183

It was then that I saw this post.

dan wendlandt (danwent) said : #5

Sorry Deepak, its not clear to me, are you still having a problem after trying:

sudo apt-get install python-pip libxslt python-setuptools python-lxml python-virtualenv
tar xzf quantum*.tar.gz
cd quantum*
sudo pip install -r tools/pip-requires
for x in client server common; do python setup_${x}.py build; done
sudo python setup.py install

Deepak Garg (deepak.garg) said : #6

Thanks Dan,
It now works.

Itzik B. (gandalf100) said : #7

Still got the same error.

dan wendlandt (danwent) said : #8

can you send the whole output of you running the commands above (feel free to use paste-bin).

Thanks.

Itzik B. (gandalf100) said : #9

Here it is:

http://pastebin.com/FQFGVkbn

Thanks

Deepak Garg (deepak.garg) said : #10

HI Gandalf,

instead of libxslt try installing libxslt-dev
Thats the package for the headers and that is what I had done and it worked for me.
 This dependency is also is a problem in nova sometimes.

Itzik B. (gandalf100) said : #11

Thanks Deepak,

Installed and tried again but still the same.

Itzik B. (gandalf100) said : #12

I created a directory named plugins under /usr/local/lib/python2.7/dist-packages/quantum_server-2012.1dev-py2.7.egg/quantum
and copied sample/* to this directory.

Now quantum-server is running.