Wine-compholio upgrade to 1.7.9 broke Netflix Desktop

Asked by Larry Barlow on 2014-01-01

Today wine-compholio upgraded from 1.7.8 to 1.7.9. Now I get an error message when loading Netflix Desktop. The error says "Couldn't load XPCOM". I tried deleting the .wine-browser directory and restarting but that didn't work. I'm running Linux Mint 16 Cinnamon edition. I have another machine running Linux Mint 16 Cinnamon edition which I have not upgraded to 1.7.9 and netflix desktop works perfertly on the second machine.

Thanks for your help.

Question information

Language:
English Edit question
Status:
Solved
For:
Netflix Desktop Edit question
Assignee:
No assignee Edit question
Solved by:
Larry Barlow
Solved:
2014-01-03
Last query:
2014-01-03
Last reply:
2014-01-02
Sebastian Lackner (slackner) said : #1

You can follow the workaround here until we've pushed out a new version of netflix-desktop:
https://bugs.launchpad.net/netflix-desktop/+bug/1265367

Larry Barlow (larry-barlow) said : #2

I installed your latest updates. Now I get an error message that says "The program container-plugin.exe has encountered a serious and must close. Sorry for the inconvenience". The machine that I haven't updated continues to work perfectly.

Thanks,

Sebastian Lackner (slackner) said : #3

Hi Larry,

I assume that it worked well on the same machine before.

Can you please show us the output of:

glxinfo

Moreover: Did you use some workarounds to disable GPU acceleration? If yes, you have to redo these workarounds, since you removed .wine-browser and reinstalled everything.

Sebastian

Larry Barlow (larry-barlow) said : #4

Yes, it worked perfectly on the first machine until wine-compholio was updated to 1.7.9.

I have tried it a couple of more times and I don't get the error message. I just got a black screen with no sound both times.

Also, I have tried both the nouveau and nvidia drivers. I'm new to your forum and I don't know how to attach a file containing the glxinfo output.

Erich E. Hoover (ehoover) said : #5

Hi Larry, the easiest way to send us the glxinfo output would be to use Pastebin or a similar service. I changed the default hardware acceleration settings for some graphics cards, so it's possible that you need to launch the application with GPU acceleration manually disabled (netflix-desktop --disable-hw-acceleration) or enabled (netflix-desktop --enable-hw-acceleration). Please give both those options a try and once you let us know which one works (and send us the glxinfo for your graphics card) we can make sure the default behavior is correct for your graphics driver.

Larry Barlow (larry-barlow) said : #6

Disabling hardware acceleration fixed it.

Thanks for your help.

Erich E. Hoover (ehoover) said : #7

Hi Larry,

Would you mind executing "glxinfo > ${HOME}/glxinfo.log" and then sending me the "glxinfo.log" file that results (using Pastebin, Dropbox, or some other service)? That will allow me to disable hardware acceleration for your graphics card automatically in future releases.

Best,
Erich

Larry Barlow (larry-barlow) said : #8

Sure, the pastebin url is http://pastebin.com/TybmrkVD.