Netflix-Desktop Won't Load, "Couldn't load XPCOM"

Asked by John B. on 2014-01-01

Updated to the newest wine-compholio this morning (Jan 1 2014) on saucy, and now when I try to load netflix-desktop I get an error message in wine "Couldn't load XPCOM". I tried rm -rf on my ~/.wine-browser directory, and when I loaded netflix-desktop again it reconfigured wine, but the same error resulted.

Thoughts? Help?

Question information

Language:
English Edit question
Status:
Answered
For:
Netflix Desktop Edit question
Assignee:
No assignee Edit question
Last query:
2014-01-01
Last reply:
2014-01-01
Darin B (darinb6-w) said : #1

same problem on linux mint 13.
It worked perfectly before the wine compholio 1.7.9 update today.

!!!

Please help.

Erich E. Hoover (ehoover) said : #2

I'm looking into it, it only seems to affect non-pipelight netflix-desktop installs so I didn't notice it when I ran my tests. I'll report back soon.

Sebastian Lackner (slackner) said : #3

You can follow the workaround here until we've pushed out a new version of netflix-desktop:
https://bugs.launchpad.net/netflix-desktop/+bug/1265367

Darin B (darinb6-w) said : #4

Latest update still gives silverlight plug in error

Darin B (darinb6-w) said : #5

It seems my previous comment didn't get posted.
i received and update and netflix opens but when i click a movie to stream it says i do not have silverlight plug in installed i attempted to install it vie wine internet explorer it seemed to install but i still get the error. I just received another update installed it and i still have no silverlight plug in netflix-desktop

Erich E. Hoover (ehoover) said : #6

Hi Darin, please delete the profile folder (rm -Rf ${HOME}/.wine-browser) and try again.

Darin B (darinb6-w) said : #7

awesome! Thank you so much. Problem solved. Have a great New Year.
D

Can you help with this problem?

Provide an answer of your own, or ask John B. for more information if necessary.

To post a message you must log in.