incoherent install

Asked by Francois Thunus on 2009-05-06

I have installed JJ remix on my son's eeePC 701. The Asus was ordered in Germany and has a german keyboard.
I decided to replace the Xandros when for some reason my son could not longer connect on the home network.
He decided that come to think of it, he'd rather have a french speaking environment. Everything went fine, but there was very little space left on the hard disk. so I dpkg-l |less to see where I could save space and I deleted at least 5 english dictionnaries (aspell-gb|us, myspell-gb|us|za) from memory. Why are those installed when the french version was installed correctly and is all he needs ? On subnotebooks, HD space is limited, so it might be nice to have a post-install routine that weeds out unecessary things. If the user wants it back, after all it is only an apt-get install away.
Cheers

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Netbook Remix Edit question
Assignee:
No assignee Edit question
Solved by:
Paul Larson
Solved:
2010-05-04
Last query:
2010-05-04
Last reply:
2009-08-14

This question was originally filed as bug #372656.

Francois Thunus (thunus) said : #1

still digging, and I found some more incoherence. For example, the packages gimp-data and gimp-help are installed, but gimp itself is not...
Cheers

Paul Larson (pwlars) said : #2

The default install for UNR does not install things like gimp or any of its dependencies. This can, however, happen by installing something, then removing it without removing it completely.

Best Paul Larson (pwlars) said : #3

There are already several options for going through the list of installed applications and removing the ones you are not interested in. dpkg, as you mentioned, is one option. Another is by going to the Add/Remove applications tool, or even Synaptic.

As for the gimp-data and gimp-help, these are not installed by default. What likely happened is that someone installed gimp to try it out, then later decided to remove it. This can sometimes leave behind some of the dependencies unless you tell it to remove them. An easy way to clean this up later is by using the command 'apt-get autoremove'.

Hope this helps

Francois Thunus (thunus) said : #4

Thanks Paul Larson, that solved my question.