ATI / AMD proprietary FGLRX graphic driver doesnt load

Asked by Zum Kuckuck on 2011-03-11

I have a new toshiba NB550D netbook and I try to install Ubuntu 10.10. But the driver doesnt install.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Netbook Remix Edit question
Assignee:
No assignee Edit question
Solved by:
Zum Kuckuck
Solved:
2011-03-14
Last query:
2011-03-14
Last reply:
2011-03-12

This question was reopened

Sam_ (and-sam) said : #1
Zum Kuckuck (aufdemwasen) said : #2

Hallo Sam
thank you for your quick answer.
Yes it is the netbook in your link and it has the new Radeon HD 6250M.
I am total new in Linux.
So I found the Ubuntu page, and I downloaded Ubuntu 10.10 for netbook and the USB-installer. I followed the instructions and at the end of installation (with USB Stick) came a message, that a driver is missing. I searched and I found System>administration>driver. I clicked and there came the message that there is a prioprietary driver for download. But the download runs very slow. Just near the end comes the message that download fails.

I like Ubuntu 10.10 but my problem is that the only possible screen resolution is 800x600.
Windows 7 runs with 1024x600 which I like more. At home I connect my Samsung SyncMaster 701 monitor. In Windows is the highest possible resolution 1280x1024 but Ubuntu has 800x600 and it cant be changed.
Does a open source driver-download solve my problem (I want to change a higher screen resolution)?

Zum Kuckuck (aufdemwasen) said : #3

Hallo Sam
I have also another problem:
I wanted

Zum Kuckuck (aufdemwasen) said : #4

Hallo Sam,
I have still another problem. I wanted to watch a clip on youtube and there came the message, that Adobe Flash Player is missing. I clicked Ubuntu Sofware-Center and started to download the Adobe Flash Player (search field at "install software"). But the download doesnt complete.

Sam_ (and-sam) said : #5

I don't know if open source driver solves your problem you just need to test it.
If there is no xorg.conf (/etc/X11/xorg.conf) you may create a standard one via CLI (ctrl+alt+t):
sudo Xorg -configure

To edit run:
gksudo gedit /etc/X11/xorg.conf

Add to 'Screen' section modes, e.g.
Modes "1280x1024" "1024x768"

Reference.
https://wiki.ubuntu.com/X/Config/Resolution#Setting%20resolution%20changes%20in%20xorg.conf%20--%20resolution%20lower%20than%20expected

https://wiki.ubuntu.com/X/Config

# de
http://wiki.ubuntuusers.de/XServer#Screen
http://wiki.ubuntuusers.de/Grafikkarten/ATI

Unfinished downloads may point to disconnected wireless, plug-in ethernate cable to proper update your system and installing drivers.

First thing after installation update your system.
Close all running package management GUIs (Software Center, Synaptic, etc.) and run via terminal (ctrl+alt+t):
sudo apt-get update
sudo apt-get upgrade
sudo apt-get -f install

https://help.ubuntu.com/community/AptGet/Howto
# de
http://wiki.ubuntuusers.de/apt-get

## Note, usually create for any issue a separate question. This makes it easier to others which may look for answers on the same or similar issue.

Zum Kuckuck (aufdemwasen) said : #6

Hallo Sam,
now I found it. It was because I was running Ubuntu 10.10 from an USB stick. And most things didnt work:
I couldnt install the AMD/ATI proprietary driver
I couldnt install Adobe Flash Player
I couldnt run my O2 Prepaid USB stick for mobile Internet. This destroyed even the system on USB. It didnt work longer and I had to use the USB Installer again.
I tried 3 days a lot of things and I was near to give up.
Then I had the idea to install Ubuntu 10.10 on my Hard Disk and voila: I could install the AMD/ATI I can chose screen resolutions like in windows and all the other things work now.
I think the Ubuntu homepage should warn new users that while running the system from USB some functions are enabled.
Thank you verymuch for your help.

Zum Kuckuck (aufdemwasen) said : #7

Sorry I wanted to write:
......................... some functions are disabled.