error make on maverick

Asked by maxfact on 2010-09-02

I'm trying to compile nautilus-on elementary maverick but I make this mistake:

"nautilus-icon-container.c: In function ‘send_focus_change’:
nautilus-icon-container.c:4851: error: lvalue required as left operand of assignment
nautilus-icon-container.c:4853: error: lvalue required as left operand of assignment"

Question information

Language:
English Edit question
Status:
Solved
For:
nautilus-elementary Edit question
Assignee:
No assignee Edit question
Solved by:
ammonkey
Solved:
2010-09-10
Last query:
2010-09-10
Last reply:
2010-09-10
Best ammonkey (am-monkeyd) said : #1

hello,

try to run ./autogen.sh --prefix=/usr first

maxfact (maxfact12) said : #2

hi
i tried but this is the answer:
beowulf@beowulf-laptop:~/nautilus-elementary$ ./autogen.sh --prefix=/usr
bash: ./autogen.sh: Nessun file o directory

maxfact (maxfact12) said : #3

I made a mistake in sending the reply does not solved the problem i apologize

ammonkey (am-monkeyd) said : #4

are you sure you're using the correct bzr branch?
the bzr branch for maverick is 2.31+ : https://code.launchpad.net/~elementaryart/nautilus-elementary/2.31+

you should have a autogen.sh script in this branch

maxfact (maxfact12) said : #5

Ah i use this:
bzr branch lp:nautilus-elementary

What is the exact syntax to download the bzr branch for maverick?

maxfact (maxfact12) said : #7

I think I have a bit of bad luck, now I have this error:
"~/2.31+$ make
make all-recursive
make[1]: ingresso nella directory «/home/beowulf/2.31+»
Making all in eel
make[2]: ingresso nella directory «/home/beowulf/2.31+/eel»
  GEN eel-makeenums-stamp
LC_ALL=C mawk -f ./maketypes.awk eel-enums.defs macros > eel-type-builtins.h
LC_ALL=C mawk -f ./maketypes.awk eel-enums.defs entries > eel-type-builtins-ids.c
LC_ALL=C mawk -f ./maketypes.awk eel-enums.defs variables > eel-type-builtins-vars.c
echo timestamp > eel-stamp
  GEN eel-marshal.h
  GEN eel-marshal.c
  CC eel-accessibility.lo
eel-accessibility.c:26: fatal error: gtk/gtk.h: Nessun file o directory
compilation terminated.
make[2]: *** [eel-accessibility.lo] Errore 1
make[2]: uscita dalla directory «/home/beowulf/2.31+/eel»
make[1]: *** [all-recursive] Errore 1
make[1]: uscita dalla directory «/home/beowulf/2.31+»
make: *** [all] Errore 2"

ammonkey (am-monkeyd) said : #8

what's your distribution?

ammonkey (am-monkeyd) said : #9

nevermind maverick
so you can get the deb files here: http://ammonkey.posterous.com/reviving-old-clutterview-code-maverick-pkg