How do I get the delete key to work in nano?

Asked by lw on 2009-05-30

Neither gnome-terminal nor xfce4-terminal seem to be able to use the Delete key properly to delete text to the right of the cursor. Auto-detect, ASCII DEL, Escape sequence and the Control-H all cause the cusor to erase text to the left of the cursor.

Question information

Language:
English Edit question
Status:
Solved
For:
nano Edit question
Assignee:
No assignee Edit question
Solved by:
Steven Danna
Solved:
Last query:
Last reply:
Revision history for this message
Best Steven Danna (ssd7) said :
#1

Try the following:

1) Open gnome-terminal
2) Goto: Edit->Profile Preferences->Compatability
3) Press "Reset Capability options to default"
4) In the terminal run:

sudo nano /etc/nanorc

change: set rebinddelete
to: unset rebinddelete

5) Save and close the file.
6) Test out your delete key in nano and see if it works like you want it to.

Revision history for this message
lw (lw-lavabit) said :
#2

Thanks Steven Danna, that solved my question.