When using fglrx, screen turns to garbage once mythfrontend starts - fine beforehand

Asked by Aaron Whitehouse on 2009-02-22

I am re-asking this question here under the correct title, as the discussion has been in https://answers.launchpad.net/mythbuntu/+question/61858 - which would make it less useful for others.

I tried switching to the non-free drivers through the "Restricted Drivers Manager". Now I just get coloured dots and shapes instead of a desktop etc. X seems pretty stuffed on both D-Sub and HDMI.
What is the easiest

 Nick Fox said 22 hours ago:
I think you might have a driver conflict if you are having these results. I
suggest checking to make sure you are actually using the correct drivers
# sudo dpkg -l | grep xorg-driver-fglrx
If you get nothing back fglrx is not installed. If it does come back with
the package info, try the following:
# sudo dpkg -l | grep ati
There should not be any ati packages other than the Ati Catalyst Control
Centre. If there are packages driver packages installed, do this:
# sudo dpkg --purge <package_name>
Then edit your xorg.conf and make sure in the device section:
Driver "fglrx"
Then restart gdm:
# sudo /etc/init.d/gdm restart
If its still not working try a reboot just for good measure.
-Nick
# sudo apt-get install --reinstall xorg-driver-fglrx

 Aaron Whitehouse said 18 hours ago:
Thank you very much for your help, Nick.
That didn't fix my problem. There was a xserver-xorg-video-ati installed, which I couldn't uninstall because it was a dependency of xserver-xorg-video-ati. I force removed that and checked the other things that you suggested, but it didn't help. Now I can't reinstall the fglrx package because it complains that -ati isn't there. Are you sure that it shouldn't be installed?
I watched more carefully this time, and the desktop comes up okay, but as soon as Mythfrontend starts, the screen goes crazy - it is like some of the pixels (only some, most of the screen is black) from a band down the left side have been stretched across the whole screen. For example, if I move to the second virtual desktop (Ctrl + Alt + Right) and click in the top left corner, a group of white dots drops down (the applications menu) across the full width of the screen.
Any further help would be excellent. If we can't sort out Fglrx, is there an easy way to go back to the stock ati driver short of reinstalling?
Is the non-free driver likely to improve performance even though no video formats are specifically accelerated (no UVD support etc.)?
 Aaron Whitehouse said 18 hours ago:
I've changed back to ati by doing a sudo apt-get -f install and then changing the xorg.conf to read "ati" in the device section.
 Nick Fox said 18 hours ago:
Aaron, I am currently in the Mythbuntu IRC support channel. If you can please join me there to work on your issue.
Channel: #ubuntu-mythtv on irc.freenode.net
Ask for help with this LP Question

Aaron Whitehouse says:

Nick, I found this, which sounds like it could be my problem:
http://www.mythtv.org/wiki/ATI_Proprietary_Driver#Garbled_Screens_with_OpenGL_Painter
do you think that is likely to be it? How do I best:

Insert the following into a startup script so that it is run before mythfrontend:

export LIBGL_ALWAYS_INDIRECT=true

Thanks in advance!

Question information

Language:
English Edit question
Status:
Solved
For:
Mythbuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Aaron Whitehouse
Solved:
2009-03-02
Last query:
2009-03-02
Last reply:
2009-02-23
Nick Fox (nickj-fox) said : #1

Aaron,

I suggest giving it a shot first, simply run the command then restart X and
see if it solves the issue, if it does we can look at the best way to get it
set at startup.

-Nick

On Sun, Feb 22, 2009 at 5:51 PM, Aaron Whitehouse <
<email address hidden>> wrote:

> New question #61979 on Mythbuntu:
> https://answers.launchpad.net/mythbuntu/+question/61979
>
> I am re-asking this question here under the correct title, as the
> discussion has been in
> https://answers.launchpad.net/mythbuntu/+question/61858 - which would make
> it less useful for others.
>
> I tried switching to the non-free drivers through the "Restricted Drivers
> Manager". Now I just get coloured dots and shapes instead of a desktop etc.
> X seems pretty stuffed on both D-Sub and HDMI.
> What is the easiest
>
> Nick Fox said 22 hours ago:
> I think you might have a driver conflict if you are having these results. I
> suggest checking to make sure you are actually using the correct drivers
> # sudo dpkg -l | grep xorg-driver-fglrx
> If you get nothing back fglrx is not installed. If it does come back with
> the package info, try the following:
> # sudo dpkg -l | grep ati
> There should not be any ati packages other than the Ati Catalyst Control
> Centre. If there are packages driver packages installed, do this:
> # sudo dpkg --purge <package_name>
> Then edit your xorg.conf and make sure in the device section:
> Driver "fglrx"
> Then restart gdm:
> # sudo /etc/init.d/gdm restart
> If its still not working try a reboot just for good measure.
> -Nick
> # sudo apt-get install --reinstall xorg-driver-fglrx
>
> Aaron Whitehouse said 18 hours ago:
> Thank you very much for your help, Nick.
> That didn't fix my problem. There was a xserver-xorg-video-ati installed,
> which I couldn't uninstall because it was a dependency of
> xserver-xorg-video-ati. I force removed that and checked the other things
> that you suggested, but it didn't help. Now I can't reinstall the fglrx
> package because it complains that -ati isn't there. Are you sure that it
> shouldn't be installed?
> I watched more carefully this time, and the desktop comes up okay, but as
> soon as Mythfrontend starts, the screen goes crazy - it is like some of the
> pixels (only some, most of the screen is black) from a band down the left
> side have been stretched across the whole screen. For example, if I move to
> the second virtual desktop (Ctrl + Alt + Right) and click in the top left
> corner, a group of white dots drops down (the applications menu) across the
> full width of the screen.
> Any further help would be excellent. If we can't sort out Fglrx, is there
> an easy way to go back to the stock ati driver short of reinstalling?
> Is the non-free driver likely to improve performance even though no video
> formats are specifically accelerated (no UVD support etc.)?
> Aaron Whitehouse said 18 hours ago:
> I've changed back to ati by doing a sudo apt-get -f install and then
> changing the xorg.conf to read "ati" in the device section.
> Nick Fox said 18 hours ago:
> Aaron, I am currently in the Mythbuntu IRC support channel. If you can
> please join me there to work on your issue.
> Channel: #ubuntu-mythtv on irc.freenode.net
> Ask for help with this LP Question
>
> Aaron Whitehouse says:
>
> Nick, I found this, which sounds like it could be my problem:
>
> http://www.mythtv.org/wiki/ATI_Proprietary_Driver#Garbled_Screens_with_OpenGL_Painter
> do you think that is likely to be it? How do I best:
>
> Insert the following into a startup script so that it is run before
> mythfrontend:
>
> export LIBGL_ALWAYS_INDIRECT=true
>
> Thanks in advance!
>
> --
> You received this question notification because you are a member of
> Mythbuntu Developers, which is an answer contact for Mythbuntu.
>

Okay, that didn't seem to work, unfortunately.

I guess that the easy option is to wait until 9.04 and try again!

According to https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/catalyst_92_linux.pdf
version 8.582:
"Resolved visible corruption when starting MythTV frontend in full screen" so maybe this is a fix for this problem. Unfortunately, there is no workaround for earlier drivers and even Jaunty is only providing 8.573 ( http://packages.ubuntu.com/search?keywords=fglrx&searchon=names&suite=jaunty&section=all ). I hope I don't have the same issue in Jaunty just because it carries a slightly older fglrx...

Excellent!

I had a go at installing the official drivers from the ATi site and I was really impressed. I'll give details for anyone else who reads this page. You download a 75MB file. Then you run the installer and it figures out what Xorg, kernel etc you have and what you need. But here is the cool part: instead of just installing, you can get it to build packages for your distribution (i.e. "Ubuntu 8.10"):
./ati-restoffilename --buildpkg Ubuntu/8.10
(you can get a list from --listpkg)
Then you install those with Gdebi and you can manage them as with normal packages.

After installing, Xv obviously works, so mplayer works with Xv and the files play as they did before. I am really surprised that nv had Xv and the radeon driver didn't, but thankfully there seems to be heaps of progress there now that ATi has opened up.

Sorry, got my "Answers" muddled up. I meant to say that, after installing, the screen is no longer turning to garbage and all works very well.

The increase in video quality was amazing. Seeing it now makes me realise how bad it was before, as everything was jerky and panning was nauseating as it jerked around. I didn't realise that Xv made that much difference.

Just for those following this as some kind of guide, you do have to change the "ati" in your /etc/X11/xorg.conf to "fglrx" (I didn't have to change anything else) - otherwise X will not work and you'll have issues.