Connecting via host and port

Asked by Darkflare on 2009-07-07

Hi

Im running mysql sandbox mysql-sandbox-3.0.04 GA and ive installed mysql-5.1.36-linux-i686-glibc23.tar.gz and it works when i navigate into the folder and run "./use"

The sandbox is running along side an old installation of mysql 4.0 something

I am trying to use this sandbox with drupal and drupal requires the following infomation to access the database:

Database name (which i ran ./use and created "drupal")
Database username (I left the defaults when i installed the msql sandbox so msandbox)
Database password (again defaults so msandbox)

database host (not sure what to use)
database port (5136)

when i try with the host as 127.0.0.1 it returns "Client does not support authentication protocol requested by server; consider upgrading MySQL client." which leads me to believe it is trying to connect to the old mysql database.

Any advice on what to do would be great as i'd quite like to get this website going.

Thanks

Alec

Question information

Language:
English Edit question
Status:
Solved
For:
MySQL Sandbox Edit question
Assignee:
No assignee Edit question
Solved by:
Giuseppe Maxia
Solved:
Last query:
Last reply:

The problem that you are experiencing is that Drupal is connecting to the database using the client libraries provided with MySQL 4.0.
The client protocol was changed in MySQL 4.1. Specifically, the password length has changed. Thus, the client (Drupal) can't understand what the server says (which is exactly what the error message you received means).

Solutions:
1) Upgrade Drupal/PHP to use a recent client library. (Can't help you here, sorry. You must ask in a specific forum)

2) Easy, but unsafe. Change the password of root and msandbox, using the OLD_PASSWORD function.
   2.1 ./use -u root
   2.2 set password=old_password('msandbox');
   2.3 set password for msandbox =old_password('msandbox');

HTH

Darkflare (msandbox) said : #2

Thanks Giuseppe Maxia, that solved my question.