mysql sandbox is giving error 'Parameter to use lib....'

Asked by junaid on 2009-01-19

Hi Sir,

I'm getting following error whenever i run following command
 perl make_sandbox /home/user/mysql-standard-4.1.22-pc-linux-gnu-i686.tar.gz

 Parameter to use lib must be directory, not file at (eval 2) line 1
 file 'VERSION' not found

My perl version details are
========================================
"This is perl, v5.10.0 built for i486-linux-gnu-thread-multi

Copyright 1987-2007, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using "man perl" or "perldoc perl". If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page."

OS Details
============
ubuntu 8.10 server edition

Thanks
Junaid.

Question information

Language:
English Edit question
Status:
Solved
For:
MySQL Sandbox Edit question
Assignee:
No assignee Edit question
Solved by:
Giuseppe Maxia
Solved:
Last query:
Last reply:

Please run the make_sandbox script as instructed in the documentation.
Non "perl make_sandbox ..."
But "./make_sandbox ..."

junaid (muhammadjunaidmalik) said : #2

Thank you so much sir.now its working fine.

Sir, I dont have much experience of Linux, can you please tell me the difference between "./make_sandbox..." & "perl make_sandbox...".

Thanks & Best Regards
Junaid.

the difference is that, in the first case, make_sandbox is a parameter to the Perl interpreter. As such, the program name is what you write in the command line.
In the second case, it's still using the Perl interpreter, but the make_sandbox script is the program. The program name is the full path to the executable script.
The script needs the program's path to do some ancillary tasks. If you start it as a bare file name, such tasks can't be performed.
It is not only Linux. This difference would stand in any operating system.

junaid (muhammadjunaidmalik) said : #4

Thank you very much sir.

junaid (muhammadjunaidmalik) said : #5

Thanks Giuseppe Maxia, that solved my question.