how fix when scripts fail on solaris due to ==

Asked by CL on 2008-12-01

I am trying to set up a test replication configuration with the mysql sandbox on Solaris 10.

I get:

-bash-3.00$ ./make_replication_sandbox -v --master_master 5.1.30
/export/home/clumpkin/sandboxes/rcsandbox_5_1_30/use_all: test: unknown operator ==
executing "clear" on node 1
executing "clear" on node 2
installing node 1
installing node 2
/export/home/clumpkin/sandboxes/rcsandbox_5_1_30/use_all: test: unknown operator ==
/export/home/clumpkin/sandboxes/rcsandbox_5_1_30/use_all: test: unknown operator ==
error starting up circular replication (Illegal seek)

What do I need to change to get it to work?

Thaks.

Question information

Language:
English Edit question
Status:
Solved
For:
MySQL Sandbox Edit question
Assignee:
No assignee Edit question
Solved by:
Giuseppe Maxia
Solved:
Last query:
Last reply:

Hi,
I thought that I had fixed this problem.
You need to replace "==" with "=".
The "==" is bash specific. If "sh" points to a different shell executable, then you have this problem

CL (cllnj) said : #2

Sorry -- what I'm not clear on is what members/where I need to make the change?

The script to change is "use_all"
you can use this command:

perl -i -pe 's/==/=/' use_all

CL (cllnj) said : #4

Thanks Giuseppe Maxia, that solved my question.