problem using sandbox with mysql-3.23.58-pc-linux-i686.tar.gz

Asked by Hugo Alvarado on 2008-08-21

Hello!

First, thanks for sandbox, it's a great idea and time saver!

But I have run into some problems. I intend to install mysql 5.0.67 and 3.23. I was able to install 5.0 and it worked great. But 3.23 is not playing along. I have mysql-3.23.57-pc-linux-i686.tar.gz and mysql-3.23.58-pc-linux-i686.tar.gz.

Both installs finish, but during the install I get:

copying current_options.conf into /home/hugo/sandboxes/msb_3_23_58
copying README into /home/hugo/sandboxes/msb_3_23_58
copying COPYING into /home/hugo/sandboxes/msb_3_23_58
copying VERSION into /home/hugo/sandboxes/msb_3_23_58
/home/hugo/Desktop/3.23.58/scripts/mysql_install_db: 73: my_print_defaults: not found
080821 17:03:46 /home/hugo/Desktop/3.23.58/bin/mysqld: Shutdown Complete

loading grants
................... sandbox server not started yet
installation options saved to current_options.conf.

The main problem seems to be at:
/home/hugo/Desktop/3.23.58/scripts/mysql_install_db: 73: my_print_defaults: not found

Also trying to ./start just hangs and prints .............. and then ends.

I use this command to install
./make_sandbox /home/hugo/Desktop/mysql-3.23.58-pc-linux-i686.tar.gz -P=3306 --force --verbose

and also tried --no_load_grant

I'm usgin ubuntu 8.10

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
MySQL Sandbox Edit question
Assignee:
No assignee Edit question
Solved by:
Giuseppe Maxia
Solved:
Last query:
Last reply:
Hugo Alvarado (hugo102) said : #1

I'm using mysql sandbox 2.0.8, also, i'm using a red shirt today, I'll try a different color tomorrow and try to install again! :-)

Thanks for your feedback.
Fixed in version 2.0.9

Hugo Alvarado (hugo102) said : #3

Thanks datacharmer, that solved my question.