How to reset root password

Asked by kenepter on 2014-11-05

After upgrade ubuntu from 14.04 to 14.10, sandbox's default password is not working. Is it a way to reset root password?

Question information

Language:
English Edit question
Status:
Solved
For:
MySQL Sandbox Edit question
Assignee:
No assignee Edit question
Solved by:
kenepter
Solved:
2014-11-06
Last query:
2014-11-06
Last reply:
2014-11-05

MySQL Sandbox is not affected by operating system changes.
Please post the details:
1) were you installing a new sandbox or using an existing one?
2) which version of MySQL?
3) which version of the sandbox?
4) what operation did you do that failed?
5) what output did you get?

kenepter (figo2476-n) said : #2

1. Using existing sandbox
2. mysql-5.5.37-linux2.6-x86_64.tar.gz
3. MySQL-Sandbox-3.0.44.tar.gz
4. mysql -u msandbox -pmsandbox --protocol=TCP -P 5537 (root is not working either)
5. ERROR 1045 (28000): Access denied for user 'msandbox'@'localhost' (using password: YES)

6. I notice that ubuntu 14.04 was using perl 5.18.2 and /usr/local/share/perl/5.18.2/MySQL contains Sandbox/ and Sandbox.pm

7. In ubuntu 14.10 perl is 5.20.1, when I run ./clear_all

Can't locate MySQL/Sandbox.pm in @INC (you may need to install the MySQL::Sandbox module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.20.1 /usr/local/share/perl/5.20.1 /usr/lib/x86_64-linux-gnu/perl5/5.20 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.20 /usr/share/perl/5.20 /usr/local/lib/site_perl .) at /home/kenpeter/sandboxes/sandbox_action line 21.
BEGIN failed--compilation aborted at /home/kenpeter/sandboxes/sandbox_action line 21.

/usr/share/perl/5.20.1 doesn't contain MySQL/ (using symbolic link can remove the error above, but I still have the wrong password. I didn't think I ever change the default password)

This does not seem to be a MySQL Sandbox problem.

You should use the script created by the sandbox software
~/sandbox/msb_5_5_37/use
if you want to use the mysql client (which, BTW, must be compatible with the version used) you should add " -h 127.0.0.1"

The Perl error that you get is probably due to the new version of Ubuntu using a different release of Perl by default. You can fix that by reinstalling MySQL-Sandbox.

kenepter (figo2476-n) said : #4

I re-install with MySQL-Sandbox-3.0.47.tar.gz and it seems working fine.