Arguments are not working

Asked by akaos on 2011-12-08

I've been trying out mysql sandbox for a couple of weeks now and I've created a dozen sandboxed mysql installations.

Everything works fine when I don't use any arguments. (ie: make_sandbox mysql-5.5.18-linux2.6-x86_64.tar.gz)

But if I try to configure the sandbox at the moment of creation (mainly folders, port and IP address) it just won't work. I've tried putting the arguments before and after the tarball without success.

To reduce complexity I've tried running it with just one argument, like so:

make_sandbox mysql-5.5.18-linux2.6-x86_64.tar.gz --sandbox_port=3307

This does not work. So far, I've been setting a different variable for the $HOME folder before each install (export HOME=/my/folder) but this is of course, not ideal.

So what am I doing wrong? Any ideas? (running centos 6.0 and mysql 5.5)

I'd appreciate any help :)

Question information

Language:
English Edit question
Status:
Solved
For:
MySQL Sandbox Edit question
Assignee:
No assignee Edit question
Solved by:
akaos
Solved:
2011-12-09
Last query:
2011-12-09
Last reply:
2011-12-09

Hi,
As of version 3.0.19, make_sandbox options are passed with the following
schema:
make_sandbox [options for make_sandbox itself] {tarball or version} --
[options for low_level_make_sandbox]

Notice the '--' after the tarball or version.

Cheers

Giuseppe

On Thursday, December 8, 2011, akaos wrote:

> New question #181323 on MySQL Sandbox:
> https://answers.launchpad.net/mysql-sandbox/+question/181323
>
> I've been trying out mysql sandbox for a couple of weeks now and I've
> created a dozen sandboxed mysql installations.
>
> Everything works fine when I don't use any arguments. (ie: make_sandbox
> mysql-5.5.18-linux2.6-x86_64.tar.gz)
>
> But if I try to configure the sandbox at the moment of creation (mainly
> folders, port and IP address) it just won't work. I've tried putting the
> arguments before and after the tarball without success.
>
> To reduce complexity I've tried running it with just one argument, like so:
>
> make_sandbox mysql-5.5.18-linux2.6-x86_64.tar.gz --sandbox_port=3307
>
> This does not work. So far, I've been setting a different variable for the
> $HOME folder before each install (export HOME=/my/folder) but this is of
> course, not ideal.
>
> So what am I doing wrong? Any ideas? (running centos 6.0 and mysql 5.5)
>
> I'd appreciate any help :)
>
>
>
>
>
>
>
> --
> You received this question notification because you are an answer
> contact for MySQL Sandbox.
>

--
The Data Charmer
http://datacharmer.org/

akaos (gozulin) said : #2

So there must be a space before AND after the two dashes. Like so:

make_sandbox mysql.tar.gz -- sandbox_port = 3310

instead of:

make_sandbox mysql.tar.gz --sandbox_port = 3310

Tricky tricky! In the low_level_make_sandbox help, it shows the option as --sandbox_port , --upper_directory, and so forth.

I advise you make it clear that it needs a space after the dashes :)

akaos (gozulin) said : #3

actually, I was wrong, here is what worked for me:

make_sandbox mysql-5.5.tar.gz -- --sandbox_port=3306 --sandbox_directory=msb5_5 --upper_directory=/home/akaos/sqlsandbox/sandboxes

so two dashes followed by a space followed by the actual low_level make commands which also include two dashes.

It would help if you put an example such as this one in the --help for both make_sandbox and low_level_make_sandbox. It would really make things clearer for newbies like myself.