Cannot connect to frontend - suggest improving documentation

Asked by Richard Banks


I was having trouble with MyMote and have finally worked it out. My problem was MyMote was finding the BE, and then the FEs. However it then gets stuck on the "Connecting... Select Frontend".

I have just solved this by using the MyMote functionality that allows you to hardcode a FE's IP address within MyMote. I'll raise this anyway, not as a question anymore but for yours and other's reference, and to provide some feedback for the manual.

The issue I was having is shown here - . I believe this is referred to in Q5 of the FAQ (if so, you should add this image to the FAQ)

I think the manual could benefit from a few more screenshots. I understand the concept of just providing links to the other content (for loopback/SQL fixes etc) however it's a big vague and daunting in the manual -

A bit more background on the actual problem:

Given I have multiple front ends working, I was also assuming the loopback and sql steps aren't relevant. This leaves the Avahi / hostname resolution step. Conceptually I am comfortable with how DNS works, but cannot get my head around what I supposed to do with Avahi.

Let's assume I only want mymote to work on my combined FE/BE only - what are the basic Avahi steps? I am running mythtv 0.23.1 via mythbuntu (on ubuntu 10.04). It's hostname is 'myth' and IP is assigned by the router - always I would be happy to try and get it working, and help you with the documentation.

Question information

English Edit question
MyMote Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Chase Douglas (chasedouglas) said :

Hi Richard,

Thanks for looking into this! I'll note that the manual is a big wiki page, but I think I have it locked so only I can edit. If you would like to participate in editing the manual and adding screenshots, I'd be happy to add you to the list of editors.

The documentation references Avahi just as a safe guard against people running Gentoo or some other system that may not have Avahi installed by default. I know Ubuntu installs it by default and my guess is that Fedora and all the other major distros have it installed too. So you shouldn't have to worry about setting it up.

Since your combined BE/FE machine is named "myth" in MythTV (whatever name shows up in MyMote is the name MythTV uses), try pinging myth.local. If "myth" is your BE/FE machine's hostname and Avahi is installed, then myth.local should resolve to and the ping should be successful.

Once pinging works, you should be able to follow the steps in the manual for adding the domain "local" to your iPhone. This will ensure that "myth.local" is used to find and connect to the frontend when MyMote starts.

Please feel free to follow up if you have any issues.


Can you help with this problem?

Provide an answer of your own, or ask Richard Banks for more information if necessary.

To post a message you must log in.