my-weather-indicator has displayed N/A for about a week

Asked by donna on 2016-04-01

My-weather-indicator isn't working properly. It has displayed N/A--not available for about a week. I've tried updating the program with no change.

Question information

Language:
English Edit question
Status:
Answered
For:
my-weather-indicator Edit question
Assignee:
No assignee Edit question
Last query:
2016-04-01
Last reply:
2016-04-02

I release a new version of MWI, please update and upgrade

D. Charles Pyle (dcharlespyle) said : #2

I saw the same thing as above. I upgraded to the latest version, per your advice, and now it doesn't work at all. Getting lots of python errors and errors about certain values needing to be specified before being imported. I just downgraded to 0.7.1 and switched to Open Weather Map just to get it working again at all (and then had to edit the /optextras.ubuntu.com/my-weather-indicator.share/my-weather-indicator/weatherservice.py file to correct the longstandingly erroneous WBW entry to WNW to finish getting it to work correctly and look right). Please let us know when the import and python errors are fixed and I will try the upgrade again. Thanks.

D. Charles Pyle (dcharlespyle) said : #3

This is the collection of errors that I saw with the new version of my-weather-indicator:

/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator:27: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator:28: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
  from gi.repository import Notify
<gettext.GNUTranslations object at 0x7f761a38c9e8>
/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/myweatherindicator.py:31: PyGIWarning: AppIndicator3 was imported without specifying a version first. Use gi.require_version('AppIndicator3', '0.1') before import to ensure that the right version gets loaded.
  from gi.repository import AppIndicator3 as appindicator
Traceback (most recent call last):
  File "/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator", line 58, in <module>
    from myweatherindicator import MWI
  File "/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/myweatherindicator.py", line 37, in <module>
    import preferences
  File "/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/preferences.py", line 30, in <module>
    import geocodeapi
  File "/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/geocodeapi.py", line 31, in <module>
    import yql
  File "/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/yql/__init__.py", line 19, in <module>
    from httplib2 import Http
  File "/usr/lib/python3/dist-packages/httplib2/__init__.py", line 51, in <module>
    import ssl
  File "/usr/lib/python3.5/ssl.py", line 90, in <module>
    import ipaddress
  File "/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/ipaddress.py", line 29, in <module>
    from geocodeapi import get_inv_direction
ImportError: cannot import name 'get_inv_direction'

D. Charles Pyle (dcharlespyle) said : #4

I ended up having my Ubuntu 16.04 system trashed by a series of new updates today, I thought I would just install a fresh copy this time to avoid potential issues that might have been caused by upgrades. Now, I get the following when trying to run my-weather-indicator in a clean install of the latest version of my-weather-indicator on Ubuntu 16.04:

$ '/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator'
/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator:27: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator:28: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
  from gi.repository import Notify
<gettext.GNUTranslations object at 0x7f31ed2aec88>
/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/myweatherindicator.py:31: PyGIWarning: AppIndicator3 was imported without specifying a version first. Use gi.require_version('AppIndicator3', '0.1') before import to ensure that the right version gets loaded.
  from gi.repository import AppIndicator3 as appindicator
/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/geocodeapi.py:30: PyGIWarning: GeocodeGlib was imported without specifying a version first. Use gi.require_version('GeocodeGlib', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import GeocodeGlib
/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/whereami.py:27: PyGIWarning: WebKit was imported without specifying a version first. Use gi.require_version('WebKit', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import WebKit
Traceback (most recent call last):
  File "/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator", line 58, in <module>
    from myweatherindicator import MWI
  File "/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/myweatherindicator.py", line 49, in <module>
    import wyahooapi
  File "/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/wyahooapi.py", line 28, in <module>
    import yql
  File "/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/yql/__init__.py", line 21, in <module>
    from httplib2 import Http
  File "/usr/lib/python3/dist-packages/httplib2/__init__.py", line 820, in <module>
    class HTTPSConnectionWithTimeout(http.client.HTTPSConnection):
AttributeError: module 'http.client' has no attribute 'HTTPSConnection'

D. Charles Pyle (dcharlespyle) said : #5

These errors have been fixed with release 0.7.10-0extras15.10.1. Thank you!

D. Charles Pyle (dcharlespyle) said : #6

Now, if only the WBW wind direction error could be fixed. That would also be really cool.

Jan Greeff (jan-verslank) said : #7

I have updated the package but the installation does not respond by indicating the release number. It also keeps showing N/A

Can you help with this problem?

Provide an answer of your own, or ask donna for more information if necessary.

To post a message you must log in.