Time in the applet differs from the system time

Asked by Stanilav on 2013-02-19

Hi.

I just installed this applet on my ubuntu 12.10 and noticed that time in this applet differs from my system time.

For example:
system time - 13:18
applet time - 11:18

As i understand its because of my time zone is UTC+02:00. Where should i change this setting?
Im using NTP for time synchronisation.

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
my-weather-indicator Edit question
Assignee:
No assignee Edit question
Solved by:
Stanilav
Solved:
2013-02-20
Last query:
2013-02-20
Last reply:
2013-02-19

Hi,

I think you can solve this problem, removing configuration:

rm ~/.config/my-weather-indicator/my-weather-indicator.conf

If it solves the problem, or not, please tell me, so I can modify the application.

Best regards.

Stanilav (s.pasynkov) said : #2

Ok, i think i understood when it happens.

I removed config, restarted applet and:
system time - 21:07
applet time - 21:01

So difference not 2 hours but 6 minutes now :)

It was the same when i started this applet in a first time after installation.
But then when i tried to locate my position at map - difference between times became that 2 hours. Only after that i wrote my previous message here :)

So now i can repeat that 2h error: Preferences - Location - Main Location - "Search location" button - left mouse click at my home - Ok.

Its not necessary for me to use that map service. It works fine for me without it too. I just checked its functionality.

But i still have difference in 6 minutes between my system time and applet time. Can you tell me please how to fix it too?

Thank you.

Stanilav (s.pasynkov) said : #3

Its interesting, but now it seems to be ok :)

I didnt make any changes in config file from yesterday. Just installed some updates this morning (and kernel updates too) and just noticed that now time is ok :)

So problem is solved for me.

Thank you for this great applet!

Hi!
I have the same problem. The time in applet differs from the system time in 6 minutes.
System time is 06:19, applet time is 06:13.
Can I fix it?

Mark Kelley (mcellius) said : #5

I'm having this problem, too. In my case, the time is wrong by six hours (I live in the Mountain Time Zone of the U.S., which is six hours to the west of UTC).

I tried following the instructions above, removing the configuration, but when I set it up again it's still the same. This is under Raring; I have two installations of Ubuntu 12.10 that are correct, another Raring that is correct, and one of 12.04 that is incorrect, too, so I doubt that the version of Ubuntu makes a difference.

rfpd (regis-dumoulin) said : #6

Deleting the configuration file does not work: all it does is reset everything to the default, including the location.

To me it looks like the time displayed is that one of the selected location as guessed by the application.
That time does not seem to take daylight saving schemes into account.

The easiest would be to fix this by not bothering with the time at location and simply display the system time instead (or at least give that option).

rfpd (regis-dumoulin) said : #7

OK, time to eat humble pie:
Deleting the configuration DOES work, at least it worked for me.

To remove ambiguities, here is what to do:
1. Delete the my-weather-indicator.conf file.
2. Restart the Weather Indicator.
3. Re-set the location(s) using the search button.

Result: The time is correctly set for the selected location(s).

Note to the developers: It may be a good idea to include a Widget style showing the same information than the Super or Full types but without the time.
Or, even better, create a "Show Time" Yes/No option applicable to the widget style selected.