How can I switch weather services?

Asked by Ross Ashley on 2012-09-11

I'd like to go to Yahoo weather service but I find no indication for this on the Preferences panel. How to edit weather source?

Question information

Language:
English Edit question
Status:
Solved
For:
my-weather-indicator Edit question
Assignee:
No assignee Edit question
Solved by:
Ross Ashley
Solved:
2012-09-11
Last query:
2012-09-11
Last reply:
2012-09-11

Sorry but I didn't understand your question. In main menu, Configuration, in the tab of weather services, you can find several services.

Ross Ashley (brashley46) said : #2

I'm not seeing a Configuration option at all in the main menu. I get a
preferences option with teh following tabs: Ubication, Units, General
options, Notifications. General options include autostart, refresh time,
and icon theme. Ubication just enables my location and one other.

On 12-09-11 03:26 PM, Lorenzo Carbonell wrote:
> Your question #208300 on my-weather-indicator changed:
> https://answers.launchpad.net/my-weather-indicator/+question/208300
>
> Status: Open => Needs information
>
> Lorenzo Carbonell requested more information:
> Sorry but I didn't understand your question. In main menu,
> Configuration, in the tab of weather services, you can find several
> services.
>

--
B. Ross Ashley
registered Linux user 548111

Ross Ashley (brashley46) said : #3

Myweather-indicator.conf file reads:

{"show-temperature2": {"default": "yes", "value": "yes"}, "notification-when-temperature": {"default": "no", "value": "no"}, "notification-when-humidity": {"default": "no", "value": "no"}, "notification-when-wind": {"default": "no", "value": "no"}, "notification-by-time": {"default": "yes", "value": "yes"}, "icon-light": {"default": "yes", "value": "yes"}, "second-location": {"default": "no", "value": "no"}, "temperature": {"default": "C", "value": "C"}, "latitude2": {"default": 0, "value": "43.653226"}, "autolocation": {"default": "no", "value": "no"}, "notification-when-condition": {"default": "no", "value": "no"}, "location": {"default": "", "value": "Toronto"}, "latitude": {"default": 0, "value": "43.653226"}, "show-notifications": {"default": "yes", "value": "yes"}, "notification-time": {"default": "5", "value": "5.0"}, "first-time": {"default": "yes", "value": "no"}, "location2": {"default": "", "value": "Toronto"}, "longitude2": {"default": 0, "value": "-79.3831843"}, "refresh-time": {"default": "5", "value": "5.0"}, "show-notifications2": {"default": "yes", "value": "yes"}, "search-string": {"default": "", "value": "Toronto,Toronto,Canada"}, "main-location": {"default": "yes", "value": "yes"}, "longitude": {"default": 0, "value": "-79.3831843"}, "show-temperature": {"default": "yes", "value": "yes"}, "search-string2": {"default": "", "value": "Toronto,Toronto Division,Canada"}, "wind": {"default": "km/h", "value": "km/h"}

Ross Ashley (brashley46) said : #4

Forget it, I've found another indicator that works on XFCE.

OK!, Ross.

I think you were using an old version of My-Weather-Indicator. If you want to use MWI, and need any help tell me.

Best regards

JWDinKC (jwdinkc) said : #6

I'm using 0.4.5.19 and all I get is N/A for all weather in my location. I installed it from your ppa so...how do I get it to work?

Same problem as JWDinKC. Version 0.4.5.19. No option to choose a particular weather service, so I'm assuming Yahoo is to blame. A FAQ or a HOWTO would be really nice.