Problem compiling project in Eclipse

Asked by Henry Contreras on 2011-11-14

Hello, and many thanks for this great app.
My question, as the title says, is related to Eclipse.
After importing the project into an eclipse workspace (Eclipse Pulsar, updated Android SDK) there seems to be compile erros in two files.

OAuthKeyFetcher.java
public int execute(...) {
...
url = new URL(context.getString(R.string.mustardoauthkeyurl)+"?"+MustardApplication.sVersionName);
--> mustardoauthkeyurl cannot be resolved or is not a field
...
}

Twitpic.java
public static String upload(...) {
...
params.add(new BasicNameValuePair("key", context.getString(R.string.twitpic)));
--> twitpic cannot be resolved or is not a field
...
}

It seems to be a problem with the SDK. Neither of the suggested "quick fixes" works, as they modify the generated R file.

Any clue on this? It's my first Android/Eclipse development test.
Thanks in advance!

Question information

Language:
English Edit question
Status:
Solved
For:
Mustard Edit question
Assignee:
No assignee Edit question
Solved by:
Michele Azzolari
Solved:
2011-11-14
Last query:
2011-11-14
Last reply:
2011-11-14
Best Michele Azzolari (macno) said : #1

You have to rename res/keys-example.xml and modify it with your values

Thanks Michele Azzolari, that solved my question.

:D
Thats a fast answer!!
Thanks!

guysoft (guysoft) said : #4

Where is keys-example.xml ?
It does not seem to be in the repo

https://www.gitorious.org/~macno/mustard/macnos-clone/trees/master/res

Thanks

Michele Azzolari (macno) said : #5

@guysoft sorry, it's in /res/values

®om (rom1v) said : #6

"modify it with your values" : how to get a value for "mustardoauthkeyurl" ?

Michele Azzolari (macno) said : #7

@om sorry for the late reply: you need to set the URL of the json file containing the OAuth key pair. File must be formatted as explained here http://mustard.macno.org/oauth