Qnx and Mosquitto

Asked by andrea on 2011-07-08

I'm Andrea and I'm developing a software for an Universitary experiment. I'd like to use as mqtt message broker mosquitto but I'm not able to compile the source code in qnx neutrino o.s. As first thing I want to ask you if mosquitto is compatible with this operating system.
Thank you very much!
I'm sorry for my English.


Question information

English Edit question
mosquitto Edit question
No assignee Edit question
Last query:
Last reply:
Roger Light (roger.light) said : #1

Good question! I've no experience of QNX, so it's a bit tricky to say. I see that QNX at least tries to be POSIX compliant so it ought to be quite straightforward to get things compiled. Could you supply an error message at the point it fails? My suggestion for the first thing to try would be disabling memory tracking (see config.h).

Roger Light (roger.light) said : #2

I've managed to get an evaluation copy of QNX 6.5 and got it going. The problems with compilation were around memory tracking and sockets but were quite easy to fix for the most part.

I've put a compiled version at http://mosquitto.org/files/binary/qnx/ - but I should warn you that I've not tried running it at all! I ran out of time before I could do that.

I've also committed the fixes to the 0.12 branch which you can get in its current state at https://bitbucket.org/oojah/mosquitto/get/537cc60251ee.tar.gz if you need to try compiling yourself.

Let me know how it goes!

andrea (deksmail) said : #3

I really don't know how to thank you for the support. Tomorrow morning I will try the version that you have compiled and I will write the results of my tests!
Thank you again Roger!


andrea (deksmail) said : #4

I could not resist! I already tried the new version, the broker seems to work well but when I lunch the mosquitto_pub or the mosquitto_sub qnx give me this error:
ldd: FATAL: Could not load library libmosquitto.so.0
Do you have the same problem?


Roger Light (roger.light) said : #5

Good to hear!

With regards to the clients, you need to give the run time linker the chance to find the library. You have two options:

* Run the command as "LD_LIBRARY_PATH=<path to libmosquitto.so.0> mosquitto_pub ....."
* Put libmosquitto.so.0 in /usr/local/lib or /usr/lib - running the clients may then "just work", I'm not sure. On Linux you'd also have to run "ldconfig" as the super user but I don't know whether that's needed on QNX.

robby0524 (robby0524) said : #6

We'll use the version 1.4.7 - 20151221 for QNX x86. But make file of the config.mk is not for QNX x86.
How to modify the make file for x86 system?
CFLAGS?=-Wall -ggdb -O2 -fstack-protector -fstack-protector-all -mcpu=cortex-a9 -V4.6.3,gcc_ntoarmv7le -D__QNX__
CPPFLAGS=-V4.6.3,gcc_ntoarmv7le -Y_gpp -D__QNX__
LDFLAGS=-V4.6.3,gcc_ntoarmv7le -Y_gpp -D__QNX__

The CPU of system is "Intel(R) Core(TM) i5-4210M CPU@2.60GHz 2.60GHz" .
QNX version is QNX 6.5.


Roger Light (roger.light) said : #7

I'm sorry I don't know - this is more of a question about how to build on qnx than a question about mosquitto. You'd be better off getting qnx support instead, I can't help with it.

Can you help with this problem?

Provide an answer of your own, or ask andrea for more information if necessary.

To post a message you must log in.