Need fix for Mixxx 1.11.0 dependencies -unable to downgrade out of Mixxx 2.0 in Ubuntu 14.04.

Asked by Jeseppi Trade Wildfeather on 2016-03-13

I was spinning quite nicely in 1.11.0. It's quick. It's snappy on my older laptop. 2.0 is slow and sluggish on my 1.8ghz system. As always you need to reinstall and refresh your happy existing software and I am having a good deal of difficulty doing this with 1.11.0. Everywhere I keep hitting: "Unable to find dependencies for mixxx-1.11.0" .

Ubunto only supports 2.0 and 1.10.0, and I can only force install 1.10.0 ...but, 1.11.0 is the love of my life and now she's gone. I want her back! After many hours I found the little widget below for installing 1.7.0 and after plugging in 1.11.0 it almost gets me there but I get hung up with "Unable to find a source package for mixxx-1.11.0" .

Who knows there way around this maze? I have the source for 1.11.0 in my Downloads folder. Read me lists the dependencies, but I'm no compiler -at least not yet.

I'm handy in the terminal and am struggling through this with an identical Gateway M460 back-up laptop I can experiment on.

Please help me fix this so I can love on my 1.11.0 a little longer. I'm a radio dj and this version has helped me immensely. It's actually changed the course of my life. I know that sounds dramatic but it's true. For many years I have been unable to take advantage of such miraculous developments until now. I am indebted to the creators for their vision and love and hope to see Mixxx prosper and grow in people's hearts as the wonderful gift that it truly is.

- Kind regards, dj Zep ... find me on Soundcloud under "Sound Alchemy".

Notes:
I'm running 14.04 on a Gateway M460, with 2gb ram, ntel® Pentium(R) M processor 1.73GHz

Here's what I've been using:

wget http://downloads.mixxx.org/mixxx-1.11.0/mixxx-1.11.0-src.tar.gz, 32-bit
cd mixxx-1.11.0
sudo apt-get build-dep mixxx-1.11.0
scons optimize=2 prefix=/usr
sudo scons install

Question information

Language:
English Edit question
Status:
Solved
For:
Mixxx Edit question
Assignee:
No assignee Edit question
Solved by:
Jeseppi Trade Wildfeather
Solved:
2016-03-14
Last query:
2016-03-14
Last reply:
2016-03-14
Daniel Schürmann (daschuer) said : #1

Please post the output of the failing build command.

You may also try to install the Sourcy package:
https://launchpad.net/~mixxx/+archive/ubuntu/mixxx/+files/mixxx_1.11.0-bzr3864-ppa1~saucy1_amd64.deb

We did a lot to make Mixxx 2.0 work smooth on old Hardware like my eeePC 901 as well.
And for me 2.0 runs faster and more stable then 1.11. Since your experience it uncommon, there might be something wrong, we can fix.

What part of 2.0 runs sluggish?

Awesome of you to get right back to me. I'm impressed and delighted!

Here's what comes up:

"wildfeather@wildfeather-Gateway-M460:~/mixxx-1.11.0$ sudo apt-get build-dep mixxx-1.11.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to find a source package for mixxx-1.11.0
wildfeather@wildfeather-Gateway-M460:~/mixxx-1.11.0$ "

Maybe there's a suffix after the version?

I'm looking forward to getting Mixxx 2.0 asap as soon as I am able to upgrade into a stronger laptop. Any recommendations? I would definitely like to keep a snappy fail safe Mixxx going as a back-up on my Gateway. The show MUST go on in this business.

What happens when I boot up Mixxx 2.0 on my system?

Seems to take a lot longer to scan my music files which have under 300 songs.
Playlists, crates, etc, no longer pop open but seem to jitter and drag.
Takes a long time to the waveforms to load up.

One the things about 1.11.0 I loved was how quickly it responded to my mouse. Sometimes I would lower the priorities through the System Monitor and move Mixxx up a notch. I also would clean caches, etc. which always helped. I'm wondering if upgrading the cpu in this old lady might be the ticket for this old lady. I've got an old Dell D620 which is a dual core. I'll get back to you on how 2.0 is working up there.

Will that "amd64.deb" package work on my 32 system?

Again, I really appreciate your help on this.

-Zep

Just got a "wrong architecture" message from Ubuntu Software Center.

Daniel Schürmann (daschuer) said : #4

Try just (without version suffix):
sudo apt-get build-dep mixxx

Here are the complete instructions:
http://www.mixxx.org/wiki/doku.php/compiling_on_linux

> What happens when I boot up Mixxx 2.0 on my system?

The new Deere and LateNight skin relay takes a lot longer to load because of svg arts. The Shade skin, optimized for Netbooks does not suffer this issue.

Scanning takes longer because of the scanning for cover arts. You can disable cover arts, display and the cover arts column.

Anything tracks takes longer because the musical key analysis. This can be disabled.

Do you use keylock? Be sure you select soundtouch for keylock engine in hardware preferences.

This is the 32 bit package:
https://launchpad.net/~mixxx/+archive/ubuntu/mixxx/+files/mixxx_1.11.0-bzr3864-ppa1~saucy1_i386.deb

The 64 bit package runs faster but requires a 64 bit system.

Thank you so much. Will look into your suggestion and let you know what happened.

Here's some feedback on my Dell system. But, before I do let me clarify what "Snappy" means to me:

"Snappy" is what truly impressed me about Mixxx 1.11.0 and what made it possible for me to succeed with djing as a new and exciting avocation.

Without "snappy" you're dead in the water.

What "snappy" means to me and many other's who depend upon Mixxx to deliver is as soon as my finger releases pressure from the mouse you're "there". Information appears in the window, lights begin to flash and the show is rolling. No hesitation. There must be no waiting. My business is all about timing and fractions of seconds. I think you know that.

Most new people who may be exploring Mixxx for the first time have older systems under 2ghz. That's who 1.11.0 was so cool. It really kicked butt. I think you made many believers. Now things are changing for the better. No doubt. But wisdom says although they are changing for you they may be more static for the average user. Perhaps you're demographics tell you different. I'd like to know. Desk computers are becoming a thing of the past. Smart phones and pads are replacing laptops which are becoming more available, albeit, mostly older models.

So what happened on my Dell?

I loaded 2.0 onto my Dell Latitude D620

-Genuine Intel® CPU T2400 @ 1.83GHz × 2
-Intel® 945GM x86/MMX/SSE2
-32-bit
-245 GB (under20GB used)

Whatever happened was quite slow if ever. Virtually, as we say about violins, "unplayable".

I quickly threw 1.10.0 back on and I can go anywhere without embarrassment except in auto dj which puts everything upside down ... only.

Funny thing is my System Monitor showed that 2.0 was using much less of the CPU than when 1.11.0 was running. Yet, the older one seemed to have more pep on my system.

No blame here.

It's probably my system. Just though you might benefit from knowing how 2.0 fares on my strong but somewhat dated laptop.

I must have "snappy" first and foremost, and the bells and whistles can come later on.
This is why it is so necessary for me and many others to opt for the older versions or at least keep them in reserve if necessary. That's why 1.11.0. For me it's like ... a workhorse.

That said, you folks are doing an incredible job to make Mixxx the best piece of software ever created for the people who love music all around. I am truly grateful and I appreciate your advise and will be happy to keep you informed of any improvements on my end.

Zep

Daniel Schürmann (daschuer) said : #6

Mixxx 2.0 should b as snappy as 1.11. If not, there is something wrong.
Please report a single action step by step that is snappy in 1.11 but not in 2.0.
Maybe I can reproduce it on my Netbook and finally fix it.
By the way, I have 2 GB Ram. How much does your system have?

Both my Gateway M460s have 2GBs and surprisingly my Dell Latitude D620
which is slower has 3GB.

On Sun, Mar 13, 2016 at 6:37 PM, Daniel Schürmann <
<email address hidden>> wrote:

> Your question #288571 on Mixxx changed:
> https://answers.launchpad.net/mixxx/+question/288571
>
> Daniel Schürmann posted a new comment:
> Mixxx 2.0 should b as snappy as 1.11. If not, there is something wrong.
> Please report a single action step by step that is snappy in 1.11 but not
> in 2.0.
> Maybe I can reproduce it on my Netbook and finally fix it.
> By the way, I have 2 GB Ram. How much does your system have?
>
> --
> You received this question notification because you asked the question.
>

Daniel,,

Here's what keeps popping up:

wildfeather@wildfeather-Gateway-M460:~/mixxx-1.11.0$ scons optimize
scons: Reading SConscript files ...
INFO:root:Target Platform: linux
INFO:root:Target Machine: i686
INFO:root:Build: debug
INFO:root:Toolchain: gnu
INFO:root:Crosscompile: NO
INFO:root:Qt path: /usr/share/qt4
Loading qt4 tool...
Deleting deprecated build file: /home/wildfeather/mixxx-1.11.0/src/build.h
Configuring MixxxCore
Checking for pkg-config (at least version 0.15.0)... yes
Configuring SoundTouch
Configuring ReplayGain
Configuring PortAudio
Checking for C library portaudio... yes
Configuring PortMIDI
Checking for C library porttime... yes
Checking for C library portmidi... yes
Checking for C header file portmidi.h... yes
Configuring Qt
Checking for QtCore (4.6 or higher)... yes
Configuring FidLib
Configuring SndFile
Checking for C library sndfile... yes
Configuring FLAC
Checking for C header file FLAC/stream_decoder.h... yes
Checking for C library libFLAC... yes
Configuring OggVorbis
Checking for C library libvorbisfile... yes
Checking for C library libvorbis... yes
Checking for C library libogg... yes
Configuring OpenGL
Checking for C library GL... yes
Checking for C library GLU... yes
Configuring TagLib
Checking for C library tag... yes
Configuring ProtoBuf
Checking for C library libprotobuf-lite... no
Checking for C library protobuf-lite... no
Checking for C library libprotobuf... no
Checking for C library protobuf... no
ERROR:root:Unmet dependency: Could not find libprotobuf or its development headers.
Configuring HifiEq
Configuring Mad
Checking for C library libmad... yes
Checking for C library libid3tag... yes
Configuring CoreAudio
Configuring MediaFoundation
Configuring HSS1394
Configuring HID
ERROR:root:Unmet dependency: 'pkg-config libusb-1.0 --silence-errors --cflags --libs' exited 1
Configuring Bulk
ERROR:root:Unmet dependency: 'pkg-config libusb-1.0 --silence-errors --cflags --libs' exited 1
Configuring VinylControl
Configuring Shoutcast
Checking for C library libshout... yes
Checking for C library libvorbisenc... yes
Configuring Profiling
Configuring Tuned
Configuring QDebug
Configuring Verbose
Configuring Optimize
Configuring FAAD
Configuring WavPack
Configuring TestSuite
Configuring LADSPA
Configuring MSVCDebug
Configuring MSVSHacks
Configuring Vamp
Checking for C library vamp-hostsdk... no
Checking for C library dl... yes
Checking for C library X11... yes
Checking for C header file fftw3.h... no
Checking for C library fftw3... no
Configuring PromoTracks
Configuring PerfTools
Configuring AsmLib
Configuring Tonal
Configuring IPod
Configuring FFMPEG
ERROR:root:Build had unmet dependencies. Exiting.

Looks like we're getting a little closer to the truth.

I wonder why after having run 1.11.0 since before Christmas I get "Dependency not satisfiablelibprotobuf-lite7: " when attempting to install:

"https://launchpad.net/~mixxx/+archive/ubuntu/mixxx/+files/mixxx_1.11.0-bzr3864-ppa1~saucy1_i386.deb"

-lite8 is in the system.

Appreciate any feedback you might have on this.

Zep

Daniel Schürmann (daschuer) said : #10

Did you call:

sudo apt-get install libprotobuf-dev protobuf-compiler

-lite8 and lite7 are not compatible
You may install the precise package
http://mirrors.kernel.org/ubuntu/pool/main/p/protobuf/libprotobuf-lite7_2.4.1-1ubuntu2_i386.deb

Daniel ... You are amazing!

After installing:

sudo apt-get install libprotobuf-dev protobuf-compiler

and then,

https://launchpad.net/~mixxx/+archive/ubuntu/mixxx/+files/mixxx_1.11.0-bzr3864-ppa1~saucy1_i386.deb

Software Center gave us its blessings and it loaded on.Only one problem remains. It seems somewhere along the way the /usr/local/share directory got corrupted and after attempting to manually drop in a mixxx/ (folder) with a copy of "skins" from the resources.

I've been getting: "Could not open skindefinition file: skin.xml".

By the way I've been using the handy alt - F2 to change permissions in share forward, each time it insults me telling me I don't belong!

Fixed! Fixed!!!! Hooooray!!!!

Bless you dear friend!! You have taken the time to respond to my need and your advise worked like a charm in my primary Gateway laptop. It's snappy as ever.

When I went through the terminal with "sudo apt-get install libpro ...." .... nothing. So, next I installed the package through Software Center, then " ...~sauc1_i386.deb" and it showed as an "upgrade" which scared the crap out of me since each time it did that "2.0" happened. This time I checked below and sure enough the sweet numbers "1.11.0" appeared and it was home free from there.

 *****I still need to tweak just a little to get the skins working right in my secondary back-up laptop.*****

You saved the day!

At the end of each radio program I always tell a little story about someone who has taught me something important. Would you please give me a short word of wisdom so I can mention your name out of WEXT 97.7, Amsterdam on my next show which will be aired early in April.

Fixed!!

Daniel Schürmann (daschuer) said : #13

Nice news.

Feel free to tell this story in your show and advertise Mixxx.

I really like to know what exactly is more snappy.
So if you have the chance to compare 1.11 and 2.0 for a single step by step action it would be nice to know.
Maybe there is a chance to fix the issues with 2.0.

Thanks again, Daniel.

Gonna reinstall the System in my back-up Gateway and install 1.11.0 fresh.

Will compare the two step by step in the areas and features I commonly use.

Good fortune in your work.

You have the gifts of talent, patience and kindness.

Shalom!