Vala problem when trying to build Midori

Asked by Gregor Petrin


I'm trying to build Midori for ARM V7. I got all the dependencies to make cmake happy but when I try 'make', the build returns the error I posted below. I tried downloading source versions 0.5.7, 0.5.9 and checking out 0.6.0 trunk, but the same error happens with all. Any suggestions on what I can try to get Midori to build? Output is from v. 0.5.9 (but it looks pretty much the same for all of them).

(valac:21346): GLib-GObject-CRITICAL **: /build/buildd-glib2.0_2.33.12+really2.32.4-5-armhf-lyFr34/glib2.0-2.33.12+really2.32.4/./gobject/gtype.c:2605: You forgot to call g_type_init()

(valac:21346): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(valac:21346): GLib-GObject-WARNING **: cannot create new instance of invalid (non-instantiatable) type `<invalid>'

** (valac:21346): CRITICAL **: vala_compiler_run: assertion `self != NULL' failed
[ 1%] Building C object midori/CMakeFiles/midori-core-vala.dir/midori-paths.c.o
gcc: error: /home/admin/midori-0.5.9/build/midori/midori-paths.c: No such file or directory
gcc: fatal error: no input files
compilation terminated.
make[2]: *** [midori/CMakeFiles/midori-core-vala.dir/midori-paths.c.o] Error 4
make[1]: *** [midori/CMakeFiles/midori-core-vala.dir/all] Error 2
make: *** [all] Error 2

Question information

English Edit question
Midori Web Browser Edit question
No assignee Edit question
Solved by:
Gregor Petrin
Last query:
Last reply:
Revision history for this message
Rico Tzschichholz (ricotz) said :

Try to compile any other vala-based project (which uses gobject) with your current setup and see what happens.

Revision history for this message
Gregor Petrin (gregap) said :

Any suggestions for as simple as possible a project I could try?

Revision history for this message
Gregor Petrin (gregap) said :

I tried building another project and I get the same error. So it is not a Midori problem, I'm closing the bug.

Nevertheless, if a kind soul has any suggestions on what I can do to fix this, I'd be grateful :)