How does one choose an application to open PDFs?

Asked by Andrew Warshall on 2012-11-27

I'm using Midori 0.4.4 linked against WebKitGtk+ 1.2.7. Clicking on a link to a PDF does nothing useful. (I get a blank page and a small window opens; according to my system monitor, nothing is being downloaded, but my CPU is working like crazy.) After consulting your FAQ, I created a file .local/share/applications/defaults.list in my home directory, reading as follows:

[Default Applications]
application/pdf=epdfview.desktop

I then restarted Midori and again clicked on a PDF link, with the same results as before. How is one supposed to indicate such a helper application? Or, if there is no way, can Midori at least be taught to bring up a "Save as" window automatically in such a case?

                  Thanks,

                  Andrew Warshall

Question information

Language:
English Edit question
Status:
Solved
For:
Midori Web Browser Edit question
Assignee:
No assignee Edit question
Solved by:
Andrew Warshall
Solved:
2013-01-08
Last query:
2013-01-08
Last reply:
2012-12-02
Christian Dywan (kalikiana) said : #1

Midori 0.4.4 is at this point fairly old, it definitely sounds like a bug (related to the download dialog from your description). Please try ppa:midori/midori-dev or ppa:elementary-os/daily if you're on an Ubuntu-based system, otherwise consider your distribution for an upgrade.

Michael Moroni (airon90) said : #2

Is it possible to add PDF.js extension? See bug 1075599 :)

Andrew Warshall (warshall) said : #3

Hi-

   The problem is solved (for me at least) in 0.4.7.

                     Thanks,

                     Andrew Warshall