Java doesn't work, applets don't show up

Created by Michael Moroni on on 2011-06-01
Keywords:
Java

Java is supported in WebKitGTK+ since 1.1.22. If you need Java, you need to upgrade to at least that version. Sun/ Oracle Java as well as IcedTea are known to work. Distribution specific setup might be required, such as setting LD_LIBRARY_PATH to include the location of libxul.so and making a symbolic link for libnpjp2.so to /usr/lib/mozilla.

icedtea6 version 1.8 and above has been known to crash midori. If this is the case for you, try sun-jre.